Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install ubuntu on a Lenovo Y500. I have disabled UEFI and Secure Boot, and reinstalled Windows. I booted from a USB key with Ubuntu 13.04 64 bit, and installed it with the bootloader installed on the '/' root partition. When I add Ubuntu to the Windows boot manager using EasyBCD with GRUB2 I get an error about not finding Ubuntu, and when I use syslinux I get a black screen.

I want to use Windows to manage the boot process, so please no solutions using ubuntu as the initial bootloader.

share|improve this question
add comment

1 Answer 1

One thing I found is that sometimes when you install from USB, the installer assigns sda to the USB instead of your hard drive. Subsequently your partition table is all messed up. You may want to check that. Generally I try to install from the CD to avoid this issue.

When I did install 13.04 (to dual boot with Win8) I had to go into the BIOS settings to change which drive boots first. Note I am trying to get GRUB to manage the boot, not Windows so we're different here.

What I have right now is that if I boot normally I get the GRUB menu which loads Ubuntu fine, but if I select Windows 8 from GRUB it fails to load Windows. If I boot the laptop using the menu button on the side I can select the Windows partition (using the Lenovo's boot order option) and Windows 8 will load fine (bypassing GRUB). So not an ideal situation but it at least works somewhat.

So I can't answer your question directly but hopefully my somewhat similar experiences will help you.

I'd be interested to know how you set Windows to manage the boot process, though.

share|improve this answer
    
To get windows to manage the boot process I select to have grub installed on '/' during ubuntu install instead of the MBR. Then in windows I install easybcd, and add ubuntu from there. The problem is that this time after selecting ubuntu in the windows boot manager it doesn't go to ubuntu. I'm not sure if I should be selecting grub2 or syslinux. tried both with no luck though. –  waspinator May 29 '13 at 15:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.