Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

EDIT: Re-opened since the errors came back. and previous solutions didn't work.

I've been happy with 13.04 since launch. This week however something odd started happening. Sometimes after login, the desktop will show, without the global menu or dock. Cannot open dash etc. Sometimes, after rebooting it would just work again, and I can continue my work.

Suddenly today, this got far worse. Now my pc will show the dock and global menu, but I cannot access the desktop (invisible icons, right-click does not work), and the background looks completely borked (see screenshot below). The mouse when over certain windows is constantly flickering.

I've attempted to completely re-install ubuntu 13.04, but even this didn't solve the problem. I have my /home on a separate partition, so I have all my current settings saved, could it be something there?

I still cannot work for long period, because the entire desktop will at random crash, and I lose all window decorations, etc.

I have a deadline for Friday, and my system is in-operable. Does anyone know how I can debug/fix this issue?

EDIT: Installing proprietary drivers does not fix the problem. In fact it results in a blank screen on boot.

EDIT: Extra info, I can boot into my windows 8 partition and play games without any display issues.

EDIT: lspci -nn output

EDIT: Today I downgraded to 12.10, using the same extended partition for my home folder. Same problems. However, if I log into a guest session, then none of these issues exist. everything works the way it normally does. Is there an issue with my home folder?

EDIT: It's starting again. Something is definitely wrong with unity in 13.04. It keeps changing my monitor settings. I boot up and see the following Monitor bug As soon as I go into the monitor settings to change the monitor settings, the UI breaks like in previous examples, and the only way to fix it is to remove the compiz-1 folder and monitors.xml folder, but after reboot I still see the two desktops overlayed like in the image.

00:00.0 Host bridge [0600]: Intel Corporation 2nd Generation Core Processor Family DRAM Controller [8086:0100] (rev 09)
00:01.0 PCI bridge [0604]: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port [8086:0101] (rev 09)
00:02.0 Display controller [0380]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0112] (rev 09)
00:16.0 Communication controller [0780]: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 [8086:1c3a] (rev 04)
00:1a.0 USB controller [0c03]: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 [8086:1c2d] (rev 05)
00:1b.0 Audio device [0403]: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller [8086:1c20] (rev 05)
00:1c.0 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 [8086:1c10] (rev b5)
00:1c.1 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 [8086:1c12] (rev b5)
00:1c.2 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 [8086:1c14] (rev b5)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev b5)
00:1d.0 USB controller [0c03]: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 [8086:1c26] (rev 05)
00:1f.0 ISA bridge [0601]: Intel Corporation Z68 Express Chipset Family LPC Controller [8086:1c44] (rev 05)
00:1f.2 IDE interface [0101]: Intel Corporation 6 Series/C200 Series Chipset Family 4 port SATA IDE Controller [8086:1c00] (rev 05)
00:1f.3 SMBus [0c05]: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller [8086:1c22] (rev 05)
00:1f.5 IDE interface [0101]: Intel Corporation 6 Series/C200 Series Chipset Family 2 port SATA IDE Controller [8086:1c08] (rev 05)
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Turks XT [Radeon HD 6670] [1002:6758]
01:00.1 Audio device [0403]: Advanced Micro Devices [AMD] nee ATI Turks/Whistler HDMI Audio [Radeon HD 6000 Series] [1002:aa90]
03:00.0 USB controller [0c03]: Etron Technology, Inc. EJ168 USB 3.0 Host Controller [1b6f:7023] (rev 01)
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller [10ec:8168] (rev 06)
05:00.0 PCI bridge [0604]: Integrated Technology Express, Inc. Device [1283:8892] (rev 30)

EDIT: Adding possible related output

$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string:   X.Org
OpenGL renderer string: Gallium 0.4 on AMD TURKS
OpenGL version string:  3.0 Mesa 9.1.1

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes

Output from unity --replace: $ unity --replace

compiz (core) - Info: Loading plugin: core
compiz (core) - Info: Starting plugin: core
compiz (core) - Info: Loading plugin: ccp
compiz (core) - Info: Starting plugin: ccp
compizconfig - Info: Backend     : gsettings
compizconfig - Info: Integration : true
compizconfig - Info: Profile     : unity
compiz (core) - Info: Loading plugin: composite
compiz (core) - Info: Starting plugin: composite
compiz (core) - Info: Loading plugin: opengl
compiz (core) - Info: Unity is fully supported by your hardware.
compiz (core) - Info: Unity is fully supported by your hardware.
compiz (core) - Info: Starting plugin: opengl
compiz (core) - Info: Loading plugin: compiztoolbox
compiz (core) - Info: Starting plugin: compiztoolbox
compiz (core) - Info: Loading plugin: decor
compiz (core) - Info: Starting plugin: decor
compiz (core) - Info: Loading plugin: vpswitch
compiz (core) - Info: Starting plugin: vpswitch
compiz (core) - Info: Loading plugin: snap
compiz (core) - Info: Starting plugin: snap
compiz (core) - Info: Loading plugin: mousepoll
compiz (core) - Info: Starting plugin: mousepoll
compiz (core) - Info: Loading plugin: resize
compiz (core) - Info: Starting plugin: resize
compiz (core) - Info: Loading plugin: place
compiz (core) - Info: Starting plugin: place
compiz (core) - Info: Loading plugin: move
compiz (core) - Info: Starting plugin: move
compiz (core) - Info: Loading plugin: wall
compiz (core) - Info: Starting plugin: wall
compiz (core) - Info: Loading plugin: grid
compiz (core) - Info: Starting plugin: grid
compiz (core) - Info: Loading plugin: regex
compiz (core) - Info: Starting plugin: regex
compiz (core) - Info: Loading plugin: imgpng
compiz (core) - Info: Starting plugin: imgpng
compiz (core) - Info: Loading plugin: session
compiz (core) - Info: Starting plugin: session
compiz (core) - Info: Loading plugin: gnomecompat
compiz (core) - Info: Starting plugin: gnomecompat
compiz (core) - Info: Loading plugin: animation
compiz (core) - Info: Starting plugin: animation
compiz (core) - Info: Loading plugin: fade
compiz (core) - Info: Starting plugin: fade
compiz (core) - Info: Loading plugin: unitymtgrabhandles
compiz (core) - Info: Starting plugin: unitymtgrabhandles
compiz (core) - Info: Loading plugin: workarounds
compiz (core) - Info: Starting plugin: workarounds
compiz (core) - Info: Loading plugin: scale
compiz (core) - Info: Starting plugin: scale
compiz (core) - Info: Loading plugin: expo
compiz (core) - Info: Starting plugin: expo
compiz (core) - Info: Loading plugin: ezoom
compiz (core) - Info: Starting plugin: ezoom
compiz (core) - Info: Loading plugin: unityshell
compiz (core) - Info: Starting plugin: unityshell
WARN  2013-05-23 02:21:03 unity.favorite.store FavoriteStore.cpp:131 Unable to load desktop file: /usr/share/app-install/desktop/opera.desktop
WARN  2013-05-23 02:21:03 unity.favorite.store FavoriteStore.cpp:144 Unable to load Favorite for uri 'application:///usr/share/app-install/desktop/opera.desktop'
WARN  2013-05-23 02:21:03 unity.glib.dbus.server GLibDBusServer.cpp:580 Can't register object 'com.canonical.Autopilot.Introspection' yet as we don't have a connection, waiting for it...
WARN  2013-05-23 02:21:03 unity.glib.dbus.server GLibDBusServer.cpp:580 Can't register object 'com.canonical.Unity.Debug.Logging' yet as we don't have a connection, waiting for it...
WARN  2013-05-23 02:21:03 unity.libindicator <unknown>:0 Desktop file '/usr/share/applications/google-chrome.desktop' is using a deprecated format for its actions that will be dropped soon.
WARN  2013-05-23 02:21:03 unity.glib.dbus.server GLibDBusServer.cpp:580 Can't register object 'com.canonical.Unity.Launcher' yet as we don't have a connection, waiting for it...
WARN  2013-05-23 02:21:03 unity.glib.dbus.server GLibDBusServer.cpp:580 Can't register object 'com.canonical.Unity.Dash' yet as we don't have a connection, waiting for it...
WARN  2013-05-23 02:21:03 unity.glib.dbus.server GLibDBusServer.cpp:580 Can't register object 'org.gnome.SessionManager.EndSessionDialog' yet as we don't have a connection, waiting for it...
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: No default decoration found, placement will not be correct
Bus error (core dumped)

broken unity desktop

share|improve this question
    
This can be a driver issue, what GPU is in the system? Have you installed any additional drivers? Can you include an lspci -nn output in your post? –  grimpitch May 23 '13 at 0:26
1  
Added the output as requests. Though I'm not sure that's it. Everything was fine up to the beginning of this week –  Andre May 23 '13 at 1:14
    
This is potentially an intel-graphics / Ubuntu 13.04 specific problem, and was caused by recent updates (around 9 days ago). I have same issue (and no ATI card). Working to resolve .. (It is not a hardware fault, or machine specific.) –  david6 May 24 '13 at 8:37
    
Hi @david6. I've managed to solve this. See my answer below. I cannot yet accept it for another couple of hours. –  Andre May 24 '13 at 10:06
    
Seems like the problem was not resolved... yet –  Andre Jun 2 '13 at 17:20
add comment

4 Answers

Andre based on the symptoms you describe this sounds like a hardware problem. Either your video card is malfunctioning or your monitor. Try a different OS or run an older version of Ubuntu via a USB drive. If the problem reappears then you most certainly have faulty hardware. Time to replace that video card likely.

share|improve this answer
    
doubt it's the video card. I can boot into my windows 8 partition without problem, and I can even play a game. Which leads me to believe that it's probably not hardware. –  Andre May 22 '13 at 23:46
add comment

I've had this happen to me on a couple of occasions, on the first it turned out the be a dying graphics card but you've just ruled that out. On the second it was caused because I had previously installed the AMD proprietary graphics drivers from the AMD website and when the kernel was updated it broke the drivers. If this is the case try using the proprietary AMD drivers or Nvidia drivers as the case may be, that come with Ubuntu 13.04, I use the AMD proprietary drivers-update without issue.

share|improve this answer
    
funny thing is, I didn't install any new drivers. I have the exact same drivers as when I upgraded. This is really strange, because I would also assume it's a hardware issue, but If I'm playing games in windows 8 without issue, then surely it's not. –  Andre May 23 '13 at 0:55
add comment

You are using the open source Gallium driver with the AMD HD 6670 graphics card, but it would be better to use the proprietary fglrx driver.

sudo apt-get install fglrx

Reboot the system and check whether the AMD binary driver is in use with the fglrxinfo, glxinfo and lsmod | grep fglrx commands.

You can refer to this guide: https://help.ubuntu.com/community/BinaryDriverHowto/ATI

share|improve this answer
    
unfortunately doing this causes a blank screen after booting, and I cannot do anything else, not even open a tty (ctrl-alt + F1). How do I revert the changes? –  Andre May 23 '13 at 10:04
1  
Boot into recovery mode and do sudo apt-get purge fglrx –  grimpitch May 23 '13 at 10:19
    
ty I'm now back into the half working desktop –  Andre May 23 '13 at 10:41
add comment

I had numerous issues with using a side by side dual monitor display until I tried disabling the video hardware acceleration. I had video corruption where both screens would become unreadable, system lock ups that required a power cord reset and numerous other issues like changing colors. Since creating and modifying the /etc/X11/xorg.conf file I have not seen a problem (about 10 days).

Note I tried using proprietary drivers and multiple other fixes without success.

On Ubuntu 13.1 you have to create the file. You cannot use a file from another machine. I tried the following from another post but it didn't work (possibly because my machine was pretty messed up by fixes). It may work for others.

switch to console mode: Alt+Ctrl+F1
kill x server: sudo service lightdm stop
generate new xorg.conf file: sudo X -configure -- this will create xorg.conf.new file in your current dir
rename and move: sudo mv xorg.conf.new /etc/X11/xorg.conf
return to GUI: sudo start lightdm

What I eventually did was boot to the command prompt skipping the display manager entirely. Either way you have to stop the X Window system to create the file. The new file is named something like xorg.conf.new. Once the file was created I renamed it to xorg.conf , edited the NoAccel line, made sure it had root ownership and put it in /etc/X11/.

Open the xorg.conf file with sudo nautilus or gksudo gedit or some other root editor. Then scroll down till you find the line that says.

#Option "NoAccel"  #[,bool>]  

and change it to

Option "NoAccel"         "True"

I don't use a desktop with lots of animations and special effects. Just two screens with one as and extension of the first so I can keep several windows open at once. This works real well for me and like I said , it's not crashing or acting up any more.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.