Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Can't get video to work in Skype! When I go into my Video Options to test video I get a black screen. I know that there is an LD_PRELOAD thing that I have to add, but for some reason it never works on 64 bit! Am I doing something wrong?

It used to work on 32 bit.

share|improve this question
Sorry - working now! Finally found what I was looking for! –  Sam H May 22 '13 at 22:19
Do you mind sharing your knowledge in a self-answer to this question? Some of us will appreciate it a lot. Thank you! –  Geppettvs D'Constanzo May 22 '13 at 22:36

2 Answers 2

Ok, so here's what I did to fix the problem:

I edited the skype.desktop file so the command to run contained the following:

bash -c 'LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/ skype %U'

Didn't need to reboot, just opened skype from the .desktop file and it works!

share|improve this answer

You should do this:

Install the libv4l 32bit version (even if you are using 64bit)

sudo apt-get install libv4l-0:i386

Locate the the path for the installed library (if there are two, chose the 32bit one - i386, ex: /usr/lib/i386-linux-gnu/libv4l/


Use the indicated path in running your command (without quotes)

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/ skype 
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.