Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to connect to a network using the options:

Wireless security: WPA & WPA2 Enterprise Authentication: TLS

I have entered values for my identity, user certificate, ca certificate, private key and private key password. However the "connect" button is greyed out. Is this dialogue performing some kind of check that is failing, or is this just a bug?

Ubuntu 12.04

share|improve this question
add comment

1 Answer

Did you figure it out? Take a look at this. Connecting with nmcli from the terminal should at the least give you an error message so you may get a clue as to what the problem is.

http://www.ubuntugeek.com/ubuntu-tiphow-to-connectdisconnect-vpn-from-the-command-line.html

If you run nmcli con list does the VPN you named show up in the list?

share|improve this answer
    
Hey, my VPN shows up on the list, but connecting via my user or via sudo gives me the same error: Error: Connection activation failed: the VPN service failed to start. –  charlie May 28 '13 at 4:14
    
Do you know which protocol your VPN host is using? Ask your VPN host or check their online documentation if available. You may need to install a different VPN package. The packages available for each protocol, according to VPNClient, are pptp-linux, vpnc an openvpn. –  RyanLoremIpsum May 29 '13 at 21:50
    
THanks! but no, as its an office network, I am blind on their config. I have a windows PC connected to the network and if there is anything I can check on it to get the info (without installing anything) then I can get it. AS far as protocols go, PAP, CHAP, EAP are disabled for me. Can you help me which packages i need to install for them to be enabled? –  charlie May 30 '13 at 3:01
    
Unfortunately, I don't know what else to suggest. If you run which openvpn and see that it is installed, you could try to re-install that package and see if it doesn't configure itself. –  RyanLoremIpsum May 30 '13 at 3:24
    
that command gave no output or errors, –  charlie May 30 '13 at 3:53
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.