Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried multiple times in terminal to change my password. but it throwing error but i filled up all requirements.

naga@naga:~$ passwd 

Current password: 
New password: 

Re-enter password: 

Password does not meet requirements
passwd: 

Authentication token manipulation error
passwd: 

password unchanged

naga@naga:~$
share|improve this question
    
Is it because your password is too simple? Just a thought :) –  Meer Borg May 22 '13 at 15:33
    
i used numeric,alphapets and special characters too in my password and it's length is 12 is it simple? –  Nagarajan anbazhagan May 22 '13 at 15:35
    
Maybe it checks small passages in the password and it contains your user name or simple passages that are forbidden. Does it work with other passwords? –  verpfeilt May 22 '13 at 16:16
    
@chocobai i checked everything but it's not working :( –  Nagarajan anbazhagan May 22 '13 at 16:23
    
I think the setuid bit has to be set on passwd or something, maybe this went somehow wrong? This is how my ls-lh looks like on passwd: -rwsr-xr-x 1 root root 46K Apr 18 03:28 passwd About setuid bit: en.wikipedia.org/wiki/Setuid I think the fourth character should be the setuid bit... or something :D –  verpfeilt May 22 '13 at 16:30

2 Answers 2

Have you tried:

Going to System Settings>User Account

  • Under Login Options:
  • Clicking where it shows bullets next to password
  • Follow the directions in the new window
share|improve this answer
    
I tried that too but I can change my new password from the generated password but I can't change it to what I want. @AnythinkM3tal –  Nagarajan anbazhagan Jul 14 '13 at 15:26

It might be because you filesystem is mounted with read-write permissions(are you in Recovery mode?).

To mount your filesystem in read-write mode, in the terminal type:

sudo mount -o rw,remount /

and then change your password using passwd <username>.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.