Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running ubuntu 13.04. I cannot get my php website to work because I cannot install php5-suhosin.

It said this each time that I have tried apt-get install php5-suhosin:

Package php5-suhosin is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

I've already done apt-get update and apt-get upgrade.

I also cannot seem to install it with compiling either. Please help! Thank you!

^^OUTDATED^^ New problem below!

Reading package lists... Done
Building dependency tree 
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
php5-suhosin : Depends: phpapi-20090626
E: Unable to correct problems, you have held broken packages.
share|improve this question
    
have you looked here? –  M.Meintjes May 22 '13 at 14:27
    
@mrseed Already tried. It does nothing. –  user160879 May 22 '13 at 14:58
    
Check this <packages.ubuntu.com/lucid/php5-suhosin>; –  Ahmadgeo May 22 '13 at 15:06
    
@Ahmadgeo That's the same thing that mrseed said. :/ –  user160879 May 22 '13 at 15:12
    
@user160879 Sorry for the dublicate link... What I meant actually is to manually download the packages you want and install them instead of using apt-get install command –  Ahmadgeo May 22 '13 at 15:22

1 Answer 1

Suhosin for PHP 5.4+ has never been finished by upstream developer in time for Debian/Ubuntu release and thus the php5-suhosin package has been dropped from Debian (and Ubuntu).

Just remove the leftovers and forget about php5-suhosin.

You don't need php5-suhosin to run the website(s) in php.

EDIT: The suhosin.org has made a new release supporting PHP5.4+ after several years of inactivity. If you really think you cannot live without it, you can compile suhosin extension yourself from source.

share|improve this answer
    
Then why doesn't my sites php scripts work? –  user160879 May 22 '13 at 17:01
5  
Then you are asking a wrong question. If your question is really about a non-working PHP, you should close this as answered (because honestly this answers your questions) and post a new question with more details about your PHP setup (packages installed, etc...). –  oerdnj May 23 '13 at 9:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.