Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Unity 2D with Compiz. And I want the workspaces button to trigger the expo view mode in Compiz. Can anyone help me?

share|improve this question

4 Answers 4

up vote 1 down vote accepted

The workspace button won't do the trick, but you can add to the launcher bar a custom button that will trigger the compiz Expo effect (thanks to Andrew from webupd8.org ).

Install xdotool (and compizconfig-settings-manager if you don't have it already) by typing in a terminal:

sudo apt-get install xdotool compizconfig-settings-manager

There is also a unity 2d tweak program, from which you can enable compositing and some other tweaks for unity 2d:

http://marianochavero.wordpress.com/2011/04/20/a-simple-gui-for-unity-2d-settings-ubuntu-11-04/

Start Compiz Config Settings Manager and set up your desired compiz effects and keyboard shortcuts. WARNING: Do NOT enable the desktop cube or the Unity plugins, as these will break the classic session. (enabling desktop cube disables all compiz plugins together with all their settings). Switching the compiz profile to "unity" instead of "default" inside the Preferences section of Compiz Config Settings Manager also breaks the classic session.

Make a expo.desktop shortcut to launch the following command:

xdotool key --clearmodifiers super+s

This will start the Expo effect. Replace super+s with the actual keyboard shortcut if you changed it. (And you can use the same procedure for other effects - I use also another launcher to trigger super+w, the Scale plugin)

You can also find a ready-made desktop file in the original post: http://www.webupd8.org/2011/05/create-custom-unity-launcher-to-trigger.html

share|improve this answer

For the record, Unity 2D should work with Compiz too. There very likely is some glitches here and there as the developers of Unity 2D do not spend time testing with Compiz but only with Metacity.

share|improve this answer

You can't. The whole point of Unity 2D is for use without Compiz. If you want Compiz support, use Unity 3D.

share|improve this answer

Use Unity 3D (instead of unity 2D, if you are using compiz).

share|improve this answer
    
unity 3d doesn't work with my very old ati graphics card –  Evan Mar 12 '11 at 9:19
    
but surprisingly compiz does –  Evan Mar 12 '11 at 9:20
1  
@Evan, not that surprising, some of the older cards lack features needed for unity 3D. You could file a bug report on Unity 2D, but it's unlikely to be added as a feature. –  RolandiXor Mar 12 '11 at 13:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.