Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I attempted to install Ubuntu 13.04 onto my secondary hard drive. I say "attempted" because I had to cancel the installation after it hung on "update-grub" (or something like that) for two or three hours. I didn't figure it was ever going to get anything accomplished, so I killed power and turned back on. Now I get a message at boot that reads,

error: file '/grub/i386-pc/normal.mod' not found

and gives me a command prompt that I have no idea what to do with. I have a primary hard drive running Windows 7, and I was attempting to install Ubuntu on a secondary drive within my computer. The installation should have installed or attempted to install GRUB to my Windows partition, since it's the drive that my computer boots from.

In troubleshooting the problem I have attempted the following to no avail:

ubuntu@ubuntu:~$ sudo mount /dev/sda1 /mnt

ubuntu@ubuntu:~$ grub-install /dev/sda --root-directory=/mnt

Resulting in the message

Path `/mnt/boot/grub' is not readable by GRUB on boot. Installation is impossible. Aborting.

That was probably because /sda1 is the Windows 7 partition. I don't really understand how or where GRUB was actually installed, or how/where I need to try to update it. So then I tried the linux partition, /sdb1

ubuntu@ubuntu:~$ sudo mount /dev/sdb1/ /mnt

ubuntu@ubuntu:~$ grub-install /dev/sda --root-directory=/mnt

Which returned

rm: cannot remove ‘/mnt/boot/grub/i386-pc/915resolution.mod’: Permission denied

So now I'm at a loss. I'm submitting this from the Ubuntu LiveCD as I have no way of logging into either Windows 7 or the Linux partition that may or may not have actually been created - I have no idea at this point, because I haven't been able to try and boot into it.

Any help would be greatly appreciated.

Thanks in advance.

share|improve this question
    
Is it a desktop computer with 2 internal HDDs? –  grimpitch May 22 '13 at 4:24
    
Yes, I have a 2TB drive that boots Windows 7, and a 500GB hard drive to which I was attempting to allocate approximately 200GB for Ubuntu. –  Chris May 22 '13 at 4:27

1 Answer 1

up vote 1 down vote accepted

You need to use the GRUB command prompt to boot the installed Ubuntu system first. Read the section "Booting Ubuntu installed on disk partitions" on this manual:

http://tuxers.com/main/instigating-a-manual-boot-from-the-grub-prompt/

Based on your HDD config, I guess your commands should be the following:

set root=(hd1,msdos1)
linux /boot/vmlinux-3.8.0-19-generic ro root=/dev/sdb1
initrd /boot/initrd.img-3.8.0-19-generic
boot

On the exact filenames, you can always use the [TAB] key.

UPDATE: Follow this procedure to reinstall:

1. Disconnect the first HDD (Windows)
2. Install Ubuntu in the usual way
3. Download and burn the Boot-Repair ISO to a CD.
4. Reconnect the first drive.
5. Boot into the Boot-Repair CD and run the recommended repair.
share|improve this answer
1  
I hope I don't sound too dense, but I read it and am still not quite sure what I need to do. Also, I don't think attempting to boot into Ubuntu will be wise, because I really don't see how it could have actually installed it - the installation had only been running for about five to ten minutes before it started starting hanging on the "update-grub" message. Would that have been long enough to format the drive and install the entire OS? It doesn't seem like it to me.. –  Chris May 22 '13 at 4:56
    
The update-grub and grub-install is executed at the end of the process. To be done in 10 minutes sounds a bit short, but it might be fine on a fast PC. –  grimpitch May 22 '13 at 5:04
    
Ok... I ran 'ls' to show me all the drives, and then 'ls (hd0,msdos1)/' and it showed me the files in that filesystem, indicating that that is my Windows 7 partition. I did this for each of the drives that it showed, and all of the other ones displayed as "unnkown filesystem." This seems to indicate that it can only recognize my Windows system, and the other partitions are there but do not have an actual operating system installed, which would seem to confirm my suspicion that Ubuntu didn't actually finish installing. What should I do from here? –  Chris May 22 '13 at 5:12
1  
If those are executed at the end of the process, then you might be right.. but why do all the drives show up as "unkown filesystem" except for the Windows one (hd0,msdos1)? Or is that what it's supposed to look like? From the manual you linked, I thought one of them was supposed to come up indicating a Linux filesystem, and that's what I needed to use, but none of them did.. I tried again just for good measure, and still no dice. Also, it's worth mentioning that (hd0,msdos1) is the first one that shows up, and that manual states that the Linux one is typically the first. –  Chris May 22 '13 at 5:21
1  
If I understand what you mean, yes - that's how I have to boot into the LiveCD. I press F-12 at the BIOS screen and I get a prompt to choose what to boot into. However, before I formatted the drive I'm currently using for Linux, I had a bootable version of Windows 7 on it (which is what my current Windows 7 drive contains a clone of), and I did not see the option to boot into it.. I don't know if the Linux partition might be different though. We'll find out soon enough I guess, I'm re-installing it now. –  Chris May 22 '13 at 6:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.