Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I don't think this is a huge problem because it seemed to be an easy fix for Ubuntu 11 and 12 so now I'm using 13.03 and cannot find a solution to my Wi-Fi problem.

My lap-top can find all the wireless networks in the area but it cannot connect to them at all. In Ubuntu 12 I used this script to connect to the wireless networks and it worked perfectly fine. I set it up so that whenever I started up Ubuntu this script would run allowing the Wi-Fi card to connect to the desired network:

echo "Type root password to enable wireless."
sudo modprobe -r iwlagn
sudo modprobe iwlagn
bt_coex_active=0
echo off

Now whenever I try to run that script this is what I get (I removed the echo off part of the script to get the output):

$ bash wifion.sh
Type root password to enable wireless.
[sudo] password for max: 
FATAL: Module iwlagn not found.
FATAL: Module iwlagn not found.

If you need any extra information please let me know and I will try to post that as well.

Thanks Max Kulik

share|improve this question
    
I guess I should also let you know know that the wired connection works perfectly fine and that I am using it right now. –  Max Kulik May 22 '13 at 2:24
    
In 13.04, the module is now known as iwlwifi. There are probably better ways to do what you are doing if you'd care to experiment. –  chili555 May 22 '13 at 2:31
    
Yeah I would have no problem doing that. –  Max Kulik May 22 '13 at 2:43
    
Really, it would just be nice to have my Wi-Fi working. –  Max Kulik May 22 '13 at 3:00

1 Answer 1

up vote 1 down vote accepted

Please create one text file:

gksudo gedit /etc/modprobe.d/iwlwifi.conf

Add one line:

options iwlwifi bt_coex_active=0

Proofread carefully, save and close gedit. Reboot and tell us if it's working correctly now.

share|improve this answer
    
I have that file already and it contains things. Should I add that as the last line? –  Max Kulik May 22 '13 at 13:44
    
Yes, please, as its own separate line. –  chili555 May 22 '13 at 18:22
    
Wow! Thanks! I knew it had to be something simple. Sorry I have not responded sooner. It's has been getting very close to the end of the school year and exams are on. This has however worked so thanks a ton! –  Max Kulik Jun 10 '13 at 21:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.