Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I am trying to update using sudo apt-get update.

receiving BADSIG error.

Get:1 raring Release.gpg [933 B]
Hit raring Release.gpg                                
Hit raring-security Release.gpg
Get:2 raring-updates Release.gpg [933 B]
Hit raring Release                                    
Hit raring-security Release                 
Hit raring-backports Release.gpg          
Hit raring/main Sources                     
Hit raring Release                      
Hit raring-security/main Sources                    
Ign raring Release                                
Hit raring/main amd64 Packages               
Get:3 raring-updates Release [40.8 kB]  
Hit raring-security/restricted Sources              
Hit raring/main i386 Packages                         
Hit raring-security/universe Sources
Hit raring-security/multiverse Sources
Hit raring-security/main amd64 Packages             
Hit raring-backports Release             
Ign raring/main Sources/DiffIndex                 
Hit raring-security/restricted amd64 Packages
Ign raring/restricted Sources/DiffIndex  
Hit raring-security/universe amd64 Packages
Ign raring/universe Sources/DiffIndex
Hit raring-security/multiverse amd64 Packages
Ign raring/multiverse Sources/DiffIndex  
Hit raring-security/main i386 Packages     
Ign raring/main amd64 Packages/DiffIndex
Hit raring-security/restricted i386 Packages
Ign raring/restricted amd64 Packages/DiffIndex
Ign raring/universe amd64 Packages/DiffIndex
Ign raring/main Translation-en_US
Hit raring-security/universe i386 Packages
Ign raring/multiverse amd64 Packages/DiffIndex
Ign raring/main Translation-en
Hit raring-security/multiverse i386 Packages
Ign raring/main i386 Packages/DiffIndex
Ign raring/restricted i386 Packages/DiffIndex
Hit raring-security/main Translation-en
Ign raring/universe i386 Packages/DiffIndex
Ign raring/multiverse i386 Packages/DiffIndex
Hit raring-security/multiverse Translation-en
Hit raring/main Translation-en
Hit raring-security/restricted Translation-en
Hit raring/multiverse Translation-en
Hit raring-security/universe Translation-en
Hit raring/restricted Translation-en
Hit raring/universe Translation-en
Get:4 raring-updates/main Sources [14.0 kB]
Get:5 raring-updates/restricted Sources [14 B]
Get:6 raring-updates/universe Sources [9,167 B]
Get:7 raring-updates/multiverse Sources [697 B]
Get:8 raring-updates/main amd64 Packages [42.5 kB]
Ign raring-security/main Translation-en_US
Get:9 raring-updates/restricted amd64 Packages [14 B]
Get:10 raring-updates/universe amd64 Packages [29.6 kB]
Ign raring-security/multiverse Translation-en_US
Ign raring-security/restricted Translation-en_US
Ign raring-security/universe Translation-en_US
Get:11 raring-updates/multiverse amd64 Packages [1,164 B]
Get:12 raring-updates/main i386 Packages [42.0 kB]
Get:13 raring-updates/restricted i386 Packages [14 B]
Get:14 raring-updates/universe i386 Packages [29.9 kB]
Get:15 raring-updates/multiverse i386 Packages [1,389 B]
Hit raring-updates/main Translation-en            
Hit raring-updates/multiverse Translation-en      
Hit raring-updates/restricted Translation-en      
Hit raring-updates/universe Translation-en        
Hit raring-backports/main Sources                 
Hit raring-backports/restricted Sources           
Hit raring-backports/universe Sources             
Hit raring-backports/multiverse Sources           
Hit raring-backports/main amd64 Packages          
Hit raring-backports/restricted amd64 Packages    
Hit raring-backports/universe amd64 Packages      
Hit raring-backports/multiverse amd64 Packages    
Hit raring-backports/main i386 Packages           
Hit raring-backports/restricted i386 Packages     
Hit raring-backports/universe i386 Packages       
Hit raring-backports/multiverse i386 Packages     
Hit raring-backports/main Translation-en          
Hit raring-backports/multiverse Translation-en    
Hit raring-backports/restricted Translation-en    
Hit raring-backports/universe Translation-en      
Hit raring/main Sources                           
Hit raring/restricted Sources                     
Hit raring/universe Sources                       
Hit raring/multiverse Sources                     
Hit raring/main amd64 Packages                    
Hit raring/restricted amd64 Packages              
Hit raring/universe amd64 Packages                
Hit raring/multiverse amd64 Packages              
Hit raring/main i386 Packages                     
Hit raring/restricted i386 Packages               
Hit raring/universe i386 Packages                 
Hit raring/multiverse i386 Packages               
Ign raring/main Translation-en_US                 
Ign raring/multiverse Translation-en_US           
Ign raring/restricted Translation-en_US           
Ign raring/universe Translation-en_US             
Ign raring-updates/main Translation-en_US         
Ign raring-updates/multiverse Translation-en_US   
Ign raring-updates/restricted Translation-en_US   
Ign raring-updates/universe Translation-en_US     
Ign raring-backports/main Translation-en_US       
Ign raring-backports/multiverse Translation-en_US 
Ign raring-backports/restricted Translation-en_US 
Ign raring-backports/universe Translation-en_US   
Fetched 213 kB in 17s (12.4 kB/s)                                              
Reading package lists... Done
W: GPG error: raring Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <>

How do I fix this?

Also getting installation errors about installing untrusted packages in ubuntu software center.

"Requires installation of untrusted packages"

   libgconf2-4 libxss1

This occurs when installing ANY application. different errors per app.

Never had this problem in Ubuntu until now. I'm about ready to leave and go back to Deb, but I like the look and feel of Ubuntu.

share|improve this question

1 Answer 1

Try all this first (as root of course):

# apt-get install -f
# dpkg --configure -a
# apt-get --fix-broken install
# apt-get --fix-missing install

If that doesn't work, try to install aptitude.

# apt-get install aptitude

And run

# aptitude update
# aptitude upgrade
share|improve this answer
This did not work, instead it crashed my pc. Instead I just tried re-installing the whole thing. Again did not work. With this I tried downloading from another source (even though the SHA and Checksum were fine) and burned again on low speed, now working fine. I wish I could figure out what happened... Just a shot in the dark, but I checked my packets on my router, and they showed that I was losing packets when initially installing and downloading initial packages, would this be why the problems were prevalent? – Lord_Rahl May 22 '13 at 3:06
@Lord_Rahl That could be the problem. I see no reason those commands would have screwed anything up; they are standard maintenance commands for broken packages and not dangerous in any way that I know of. – bntser May 22 '13 at 3:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.