Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install the meld diff viewer on Ubuntu 12.04 LTS. When I run

sudo apt-get install meld

I get the following output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libgtksourceview2.0-0 libgtksourceview2.0-common python-glade2 python-gnome2 python-gtksourceview2
  python-pyorbit
Suggested packages:
  python-gtk2-doc python-gnome2-doc libgtksourceview2.0-dev python-pyorbit-dbg
The following NEW packages will be installed:
  libgtksourceview2.0-0 libgtksourceview2.0-common meld python-glade2 python-gnome2
  python-gtksourceview2 python-pyorbit
0 upgraded, 7 newly installed, 0 to remove and 57 not upgraded.
Need to get 0 B/1,048 kB of archives.
After this operation, 5,255 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Selecting previously unselected package libgtksourceview2.0-common.
(Reading database ... 60%dpkg: unrecoverable fatal error, aborting:
reading files list for package 'python-aptdaemon.gtk3widgets': Input/output error
E: Sub-process /usr/bin/dpkg returned an error code (2)

Is there something wrong with the package libgtksourceview2.0-common? Is there a way to get a better update, or another way to get meld installed? I am uncertain how to proceed...

share|improve this question
1  
Did you tried with aptitude: sudo aptitude install meld? –  Radu Rădeanu May 21 '13 at 23:06
    
Your command syntax is unfamiliar to me. Normally when using the advanced package tool it is "apt-get". Can you elaborate? –  txmystic May 22 '13 at 4:20
    
Try sudo apt-get install --reinstall python-aptdaemon.gtk3widgets –  grimpitch May 22 '13 at 8:53
    
reinstallation of the package gives the same error again. –  txmystic May 22 '13 at 18:49
    

3 Answers 3

There is nothing wrong with the package, the install on my 12.04 system worked just fine. Try to update your dateabase first, then do the install:

sudo apt-get update
sudo apt-get install meld
share|improve this answer
    
Thanks. I should have mentioned I had already run update. I re-ran update but still the same error as described above. –  txmystic May 22 '13 at 4:22

I just tried installing Meld on my 12.04 installation, using sudo apt-get install meld, and it worked with no problems.

Try this. Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get update && sudo apt-get upgrade
sudo apt-get install meld

If that dosen't work, try installing the latest python

sudo apt-get install python3
share|improve this answer
    
The upgrade failed with the same error (at 60% dpkg: unrecoverable fatal error). And I do not want to install python3 yet, I'm doing a project that requires 2.7 and I already have a side installation of 3.3.1. Is there any way to exploit that? –  txmystic May 22 '13 at 18:48

Just use sudo aptitude install meld.

If you are not familiar with aptitude, check this post: Aptitude vs. apt-get: Which is the recommended (aka the “right”) tool to use?

aptitude and apt-get work the same for many tasks, but for the most tricky cases, such as distribution upgrades (apt-get dist-upgrade vs. aptitude full-upgrade), they have different rules, and aptitude's rules are nearly always better in practice where they disagree.

If you don't have installed aptitude, use apt-get:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install aptitude
share|improve this answer
    
I read the other post. My take is that although aptitude has some advantages, it did not seem to be a universal preference. Regardless, the upgrade itself failed with the same error (see comment in Mitch's answer) –  txmystic May 22 '13 at 18:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.