Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 13.04 as a replacement to my old 12.10 installation from a usb pendrive. The install went perfectly fine.However,when I rebooted,my computer did not detect ubuntu and got stuck on the please insert proper boot media screen.

I have used ubuntu exculsively from ubuntu 11.10,With all of them fresh installs.My most recent installation is Ubuntu 12.10 64-bit,and it worked perfectly.

I tried installing ubuntu 13.04 by overwriting 12.10,but then all of this happened.

It seems my computer cannot detect 13.04 at all,as my UEFI BIOS does not detect the os either.I have reinstalled ubuntu 13.04 two or three times to no avail.I have tried some other solutions like trying to reinstall grub

but then I am a noob and i probably messed it up.I Suspect the problem is either the UEFI or GRUB.I have ensured that grub is installed on my system however.

Please advise on how to make ubuntu boot again.I do not mind re partitioning the computer and whatnot as i have backed up all important data.I would also ask for the solution in idiot-proof terms,(like copy pasting commands).

If you need my hardware configuration,let me know,but i suspect this is a fault on ubuntu's end.

Thank you

share|improve this question
3  
Can you try Recommended Repair using boot-repair and include the URL given by the tool, if that tool doesn't solve the problem –  Web-E May 21 '13 at 15:08
    
What type of Ubuntu are you installing? 32 or 64-bit? –  nerof61 May 21 '13 at 16:46
    
I have tried using boot repair and it says it suceeded,but when i rebooted it didn't work.The url is [link]paste.ubuntu.com/5699702 The version of ubuntu im installing is 64 bit –  fanetarz May 25 '13 at 10:04
    
Can you check with sudo efibootmgr which entries are listed in NVRAM and eventually paste the output here? You could try to reinstall grub-efi-amd64 in a chrooted environment, with /dev /sys and /proc mounted on your /sda2 target. –  Mike C. May 27 '13 at 20:49
    
output:BootCurrent: 0003 Timeout: 3 seconds BootOrder: 0003,0002,0001 Boot0001* Hard Drive Boot0002* CD/DVD Drive Boot0003* UEFI: Generic Flash Disk 5.00 –  fanetarz May 28 '13 at 8:16
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.