Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Windows 8 from a VirtualBox machine inside Ubuntu 13.04, and I'm having some problems navigating in the virtual machine.

Many of the navigation options in Windows 8 (the new start menu, for instance) are accessible by moving the cursor to various corners and edges of the screen - this conflicts with my Unity desktop, in which I've mapped the corners to stuff as well using the Ubunut Tweak tool.

Is there any way to tell Unity and/or VirtualBox that when I run a virtual machine in full screen, I want these events forwarded to the guest OS, and no action on the host?

This behavior applies also to the Windows button (between left Alt and Fn on my keyboard), which triggers the Unity launcher instead of the Start menu, even when in fullscreen.

share|improve this question
    
There seems to be some setting I'm missing - I can't even press Alt+F4 and get it forwarded to the guest OS. In Windows 8, not being able to use a keyboard shortcut like that one really is a showstopper... Not even Escape is working. –  Tomas Lycken May 21 '13 at 11:27
    
Would running the VM in a GNOME "classic" fallback session be an option for you, or do you need to have Unity on the host? –  Takkat May 21 '13 at 11:33
    
@Takkat: I really would like to get this working in Unity - I'm all for the eye candy ;) I've found that it sometimes works and sometimes not, so apparently there's some setting that I inadvertently keep turning on and off again. In other words, it is possible - if I can just figure out which setting I'm meddling with, what it should be, and how to stop meddling with it. –  Tomas Lycken May 21 '13 at 12:08
1  
@mreq: I've worked some more on this, and I've noted that this almost always seems to be related with the windows key triggering the Unity launcher - when that happens, the guest OS loses some or all focus, and everything stops working. I can usually get it working again by closing the launcher, pausing and unpausing the virtual box, but this severely impedes my workflow... –  Tomas Lycken May 21 '13 at 14:08
1  
I've noted an interesting workaround: When I press the Windows key, both Ubuntu and Win8 catches it, resulting in the start menu being showed but focus being on the Unity launcher (which is still invisible, since I'm in fullscreen). Pressing the Windows key again closes the launcher and gives back focus to the guest OS - but this keypress isn't forwarded to Win8. So by pressing it twice in a row, I'm effectively pressing it once in Win8. I still haven't worked out how to get things like the right-side bar working properly, but this is a great improvement. –  Tomas Lycken May 23 '13 at 20:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.