Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an HP Pavilion G6-2303sh d4y36ea notebook. I installed Ubuntu 12.04. I had to update the kernel to 3.6.6 because the default didn't support the Ralink RT3290 wifi card. Now I'm trying to get the hybrid graphics working using this method: http://ubuntuforums.org/showthread.php?t=1930450&page=80

When dpkg configures fglrx I get this error:

Loading new fglrx-8.961 DKMS files...
Building only for 3.6.6-030606-generic
Building for architecture x86_64
Building initial module for 3.6.6-030606-generic
ERROR (dkms apport): kernel package linux-headers-3.6.6-030606-generic is not supported
Error! Bad return status for module build on kernel: 3.6.6-030606-generic (x86_64)
Consult /var/lib/dkms/fglrx/8.961/build/make.log for more information.

/var/lib/dkms/fglrx/8.961/build/make.log contains this:

DKMS make.log for fglrx-8.961 for kernel 3.6.6-030606-generic (x86_64)
2013. máj. 21., kedd, 12.25.03 CEST
AMD kernel module generator version 2.1
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
make -C /lib/modules/3.6.6-030606-generic/build SUBDIRS=/var/lib/dkms/fglrx/8.961/build/2.6.x modules
make[1]: Entering directory `/usr/src/linux-headers-3.6.6-030606-generic'
CC [M]  /var/lib/dkms/fglrx/8.961/build/2.6.x/firegl_public.o
/var/lib/dkms/fglrx/8.961/build/2.6.x/firegl_public.c: In function ‘KCL_MEM_AllocLinearAddrInterval’:
/var/lib/dkms/fglrx/8.961/build/2.6.x/firegl_public.c:2122:5: error: implicit declaration of function ‘do_mmap’ [-Werror=implicit-function-declaration]
/var/lib/dkms/fglrx/8.961/build/2.6.x/firegl_public.c:2122:13: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
/var/lib/dkms/fglrx/8.961/build/2.6.x/firegl_public.c: In function ‘kasInitExecutionLevels’:
/var/lib/dkms/fglrx/8.961/build/2.6.x/firegl_public.c:4157:5: error: ‘cpu_possible_map’ undeclared (first use in this function)
/var/lib/dkms/fglrx/8.961/build/2.6.x/firegl_public.c:4157:5: note: each undeclared identifier is reported only once for each function it appears in
/var/lib/dkms/fglrx/8.961/build/2.6.x/firegl_public.c:4157:5: warning: left-hand operand of comma expression has no effect [-Wunused-value]
cc1: some warnings being treated as errors
make[2]: *** [/var/lib/dkms/fglrx/8.961/build/2.6.x/firegl_public.o] Error 1
make[1]: *** [_module_/var/lib/dkms/fglrx/8.961/build/2.6.x] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.6.6-030606-generic'
make: *** [kmod_build] Error 2
build failed with return value 2

Aticonfig says that it could not find a supported adapter. How can I solve this problem?

share|improve this question

1 Answer 1

The problem turned out to be that, the tutorial linked to an older version of the driver, not supporting Quantal and Raring. Also I had to build the driver package for Raring, and that supports newer kernels.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.