Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It's been a struggle every time I've tried to change my OS on this machine. I honestly don't even know how it works whenever it does. I've somehow managed to get Windows 7, Windows 8, Mint 14, Ubuntu 12.04, and 12.10 to work at random times but it's always after struggling with it and googling for random chance fixes and suddenly something clicks and it loads from usb, but 99% of the time, every time I try to boot from USB to install a distro (in this case, I'm trying to get ubuntu-12.04.2-desktop-amd64.iso to work) my pc just comes up with a grub menu ("Minimal bash-like blahblahblah - grub >")

I don't know why it works when it works. Right now I've tried everything from with/without Fast Boot in BIOS, with/without CSM, with/without secure boot, to changing BOOTx64.EFI to bootx64.efi to downloading a new bootx64.efi to copying it to every folder on the usb....

It makes no sense to me. Sorry if this has been asked before but I can't find anything

share|improve this question
    
Did you enable legacy support for USB drives? –  Mike C. May 31 '13 at 23:33
    
Make sure you disable Secure Boot in the Bios, and add the boot device to the boost options (they have to be explicitly added). The order in which you do this can be tricky. –  alfC Jul 2 '13 at 5:52

1 Answer 1

This is what works for me: Turn on CSM, then change the boot order so that the USB drive(s) are listed at the top before the hard drive. Then reboot and you should be able to boot to the usb stick.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.