Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've plugged in a projector into my laptop and I'm attempting to extend the desktop onto it (so that I can run a full screen app on the projector and have the controls on my laptop).

I'm able to mirror the screens effectively (it does this by default) but I can't extend it. When I untick "Mirror screens" and press apply it asks me to log out and then back in again but it goes back to mirroring the screens.

I'm able to extend desktop on to my external monitor at home, just not this projector. Is there a manual way or other way to do this other that through Monitors setting?

My computer model is Dell Studio 1555: Pentium Dual Core T4300(2.1GHz,800MHz,1MB), 4096MB 800MHz DDR2 Dual Channel, 512 MB ATI Mobility RADEON HD 4570 using the ATI proprietary driver. My screen resolution is 1366x768 (16:9)

The projector that it wont connect properly is a Hitachi CPX3. That page specifies that it's especially designed for projectors that use 16:10 aspect ratio, but considering my external monitor at home uses 4:3 should the differences in aspect ratio matter or be causing this error?

share|improve this question
1  
The aspect ratio shouldn't be a problem, but can you post a screen shot of catalyst and the settings you are using? I haven't used an ATI in a while :(, so I can't answer with surety off hand, but it sounds to me like you just have the settings configured incorrectly. –  RolandiXor Mar 10 '11 at 15:04
    
@RolandTyalor It turns out doing it through the gnome monitor settings didn't work but through the catalyst settings it workd –  hellocatfood Mar 13 '11 at 15:59
    
can you please post an answer to this question and mark it as solved? –  RolandiXor Dec 28 '12 at 16:05
add comment

5 Answers 5

There is option in System Settings Go to System Settings -> Displays
And Untick the Mirror Display option. And hit apply
You are done ! Enjoy your extended Desktop

share|improve this answer
add comment

You can try hit win+P this shortcut configures the monitors switching between mirroring and extending the new output.

share|improve this answer
    
are you sure this works in Ubuntu without any extra software? –  ericosg Oct 16 '12 at 8:41
    
Yes. But I'm not sure about unity. –  MaikoID Oct 16 '12 at 12:33
add comment

You can go to settings, display. If you plug in another monitor devices, it will be detected there. From there, simply choose which device you want to project the screen.

share|improve this answer
add comment

It is my understanding that laptops cannot use a dual screen feature. You may want to check the specs of your machine, otherwise, you may just be running into a wall. Let me be a little more specific, it is my understanding that you cannot extend your desktop onto a second screen with monitors. That feature would rely on the graphics card.

share|improve this answer
    
I'm using my netbook and an external monitor right now to dual screen. –  lazyPower Apr 10 '11 at 9:04
    
yeah laptops can dual screen just as much as towers, it all depends on the graphics card, if you see a DVI or VGA connection on the side, you can extend your desktop, if not, you can't. :) –  Grant Jun 9 '11 at 22:39
add comment

You can manually tweak the settings using xrandr, and there is a Ubuntu wiki page describing that in more detail.

share|improve this answer
    
I'm using the proprietary driver, which renders xrandr useless –  hellocatfood Apr 8 '12 at 17:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.