Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using GEdit 3.8.2 on Ubuntu 13.04 Raring Ringtail with GNOME 3.8. I have two user accounts on my computer.

When I launch GEdit in my account, I get a window that is blank, and am not able to create or open any files. The terminal output shows:

(gedit:16768): GLib-GObject-WARNING **: cannot register existing type `GtkSourceView'`

(gedit:16768): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed

(gedit:16768): GLib-GObject-CRITICAL **: g_type_get_qdata: assertion `node != NULL' failed

(gedit:16768): GLib-GObject-CRITICAL **: g_type_get_qdata: assertion `node != NULL' failed

(gedit:16768): GLib-GObject-CRITICAL **: g_type_set_qdata: assertion `node != NULL' failed

(gedit:16768): GLib-GObject-WARNING **: cannot register existing type `GtkSourceBuffer'

(gedit:16768): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed

(gedit:16768): GLib-GObject-CRITICAL **: g_type_get_qdata: assertion `node != NULL' failed

(gedit:16768): GLib-GObject-CRITICAL **: g_type_get_qdata: assertion `node != NULL' failed

(gedit:16768): GLib-GObject-CRITICAL **: g_type_set_qdata: assertion `node != NULL' failed

(gedit:16768): GLib-GObject-WARNING **: cannot register existing type `GtkSourceLanguage'

(gedit:16768): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed

In any other account or as root, GEdit works normally. Please help!

share|improve this question
    
Have you tried reinstalling it? sudo apt-get install --reinstall gedit –  Salem May 20 '13 at 20:57
    
Yes, I've tried reinstalling...but to no avail. –  UbuntuGNOME May 21 '13 at 15:38

1 Answer 1

up vote 2 down vote accepted

I had this problem too and the fix for me was to open dconf-editor and reset the filebrowser plugin settings:

Screenshot of resetting gedit setting in dconf-editor

I believe the problem for me was a root directory existing but not having sufficient permissions to read it. If that doesn't work you should probably go through all gedit settings for the user and reset to default.

EDIT

After this bug reappeared for me I did some grunt work and tracked this down to the "Code comment" plugin. To solve this open dconf-editor and navigate to org=>gnome=>gedit=>plugins=>active-plugins and either remove 'codecomment' or click "Set to Default".

enter image description here

The GNOME Bugzilla report is here: https://bugzilla.gnome.org/show_bug.cgi?id=700867

share|improve this answer
    
Thank you so much! It's so good to have my favorite text editor back! –  UbuntuGNOME May 22 '13 at 19:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.