Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I hear my echo from speakers. If I say something its looping and resonate. How to turn microfone sound output off? We don't have Hardware tab at Sound Settings in 13.04

share|improve this question
add comment

3 Answers 3

Open the Terminal and type alsamixer, press the arrow keys to place under Mic and press M. Once done press Esc

Edited:

There are actually two parts in alsamixer, first is playback and other is recording. The above only disables playback of sound from Mic, i.e. it will not mute the mic.

As recording is different, if you record a sound even with the above option, laptop will still record the sound but it will not producing those sound the speaker.

For muting the Mic, you will need to mute the mic from recording option in alsamixer.

share|improve this answer
    
I need to speak to this microphone and don't want to hear myself from speakers. I can't turn off microphone –  Robotex May 24 '13 at 8:08
add comment

In case you don't want to mute the microphone from alsamixer you may be able to change the audio profile by installing and running pavucontrol Install pavucontrol:

enter image description here

In the Configuration tab make shure you disable the "Duplex" profile by choosing something like "Analog Stereo Output" to disable audio loop back from the microphone to the speakers.

share|improve this answer
add comment

Install and start alsamixer (gnome alsamixer or alsamixergui are GUI version)

Find the mixer for your output device (you might have multiple, e.g. built-in analog, hdmi, usb headset etc.)

If you are lucky you can control how much of the sound of your input device (mic) goes to output (this is different from setting the input level)

Figure out which slider controls it (Mic, Front Mic, Rear Mic, Capture, etc) and set it to minimum or "Mute" if available.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.