Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

gvfs is mounting my phone automatically when I plug it in, I don't want this for various reasons.

How do I disable automatic mounting for this specific device, but continue allowing other USB devices to automount?

Here's the mount after plugging in :

~$ gvfs-mount -l
Drive(0): ST320LT007-9ZV142
  Type: GProxyDrive (GProxyVolumeMonitorUDisks2)
Drive(1): HL-DT-ST DVD+/-RW GU60N
  Type: GProxyDrive (GProxyVolumeMonitorUDisks2)
Drive(2): Generic Ultra HS-SD/MMC
  Type: GProxyDrive (GProxyVolumeMonitorUDisks2)
Volume(0): Galaxy Nexus
  Type: GProxyVolume (GProxyVolumeMonitorMTP)
  Mount(0): Galaxy Nexus -> mtp://[usb:002,020]/
    Type: GProxyShadowMount (GProxyVolumeMonitorMTP)
Mount(0): mtp -> mtp://[usb:002,020]/
  Type: GDaemonMount

Update Tue May 21 00:03:00 EDT 2013:

I found /usr/share/gvfs/mounts/mtp.mount which contains:


Unhappily this AutoMount parameter doesn't seem to do anything.

In the meantime I've followed advice from here and disabled automount-open and automount in the gconf settings under This disables it globally but it's better than the alternative. Here's hoping we'll have device- or protocol-specific (or both!) gvfs automount configuration in the future.

share|improve this question

closed as off-topic by bain, bodhi.zazen, psusi, Warren Hill, Sneetsher Jun 28 '14 at 14:30

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

I'm not sure you can sorry... – Ads20000 May 20 '13 at 17:09
Take a look at This and see if it helps. – Mitch May 20 '13 at 18:15
@Mitch thanks, but gnome-disks doesn't manage gvfs mounts, that's for stuff in /etc/fstab. – wastrel May 21 '13 at 3:39