Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed ubuntu 13.04 32bit on my iMac (21 inch). I can see some networks, both wep and wpa, but not mine and some others.

mine is on channel 13, I think is that the problem. I've tried the solutions indicated here for similar problems creating an 'options' file in /etc/modprobe.d and insert the line 'options cfg80211 ieee80211_regdom"EU"' (tried also with the line 'cfg80211 ieee80211_regdom"EU"', because i find both indicated as the good ones in forum).

I also tried to connect using 'connect to a hide network' but not work. everithing stay the same. I have no access to the router so can't change the channel and I have no others network so the iMac cannot connect to the web.

The only support I had is another mac wich using the network that I can't use on the iMac (so the network is absolutely not the problem :D ).

what can I do? (before reinstalling snow leopard xD)

here are some details:

    :~$ dmesg | grep cfg80211
[   15.539410] cfg80211: Calling CRDA to update world regulatory domain
[   16.088032] cfg80211: World regulatory domain updated:
[   16.088036] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   16.088039] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   16.088042] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   16.088044] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   16.088047] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   16.088049] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   16.676062] INFO @wl_cfg80211_attach : Registered CFG80211 phy

and

> ~$ sudo iwlist wlan0 channel
> no frequency information.

and the driver : broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source(open source)

sorry for the long silence, here are some additional informations you asked me couple of months ago:

:~$ sudo iwlist eth1 channel
    eth1      32 channels in total; available frequencies :
              Channel 01 : 2.412 GHz
              Channel 02 : 2.417 GHz
              Channel 03 : 2.422 GHz
              Channel 04 : 2.427 GHz
              Channel 05 : 2.432 GHz
              Channel 06 : 2.437 GHz
              Channel 07 : 2.442 GHz
              Channel 08 : 2.447 GHz
              Channel 09 : 2.452 GHz
              Channel 10 : 2.457 GHz
              Channel 11 : 2.462 GHz
              Channel 12 : 2.467 GHz
              Channel 13 : 2.472 GHz
              Channel 14 : 2.484 GHz
              Channel 32 : 5.16 GHz
              Channel 34 : 5.17 GHz
              Channel 36 : 5.18 GHz
              Channel 38 : 5.19 GHz
              Channel 40 : 5.2 GHz
              Channel 42 : 5.21 GHz
              Channel 44 : 5.22 GHz
              Channel 46 : 5.23 GHz
              Channel 48 : 5.24 GHz
              Channel 50 : 5.25 GHz
              Channel 52 : 5.26 GHz
              Channel 54 : 5.27 GHz
              Channel 56 : 5.28 GHz
              Channel 58 : 5.29 GHz
              Channel 60 : 5.3 GHz
              Channel 62 : 5.31 GHz
              Channel 64 : 5.32 GHz
              Channel 66 : 5.33 GHz

and i put 'options cfg80211 ieee80211_regdom=FR' (without the tickmarks) in a file named 'options' that I create in /etc/modprobe.d/ everithing stay the same exept that I use the other mac to share the internet connection via ethernet so I have now internet on this problematic Mac.

Thanks for the help, Michele

share|improve this question
    
First of all, I don't believe EU is a recognized ieee80211 code: en.wikipedia.org/wiki/ISO_3166-1_alpha-2 You might try DE or FR or the actual country. Second, I believe the correct usage is: 'options cfg80211 ieee80211_regdom=FR' without the tickmarks, of course. After you amend your file and reboot, check dmesg for relevant messages or errors: dmesg | grep regdom –  chili555 May 20 '13 at 17:08
    
I've tried editing options as you suggest and restart but nothing change. I put dmesg | grep regdom in terminal but it return nothing, it is good? –  mikysett May 20 '13 at 22:41
    
We would love to see: dmesg | grep cfg80211; also : sudo iwlist wlan0 channel. What wireless driver is being used? –  chili555 May 21 '13 at 10:52
    
I had this informations on the bottom of the topic, let me know if it help :) –  mikysett May 22 '13 at 20:52
    
The STA driver uses the interface eth1 and not wlan0,so please let us see: sudo iwlist eth1 channel. This part: "cfg80211: World regulatory domain updated: " indicates a default regulatory domain, not any specific country code. Please recheck your options file. What is it named? Is it exact contents: 'options cfg80211 ieee80211_regdom=FR' without the tickmarks, of course? What does this report? iw reg get –  chili555 May 23 '13 at 2:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.