Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to get working touchscreen Nexio NOP 190 IR in Ubuntu 12.04. I can't find any useful information. Here is dmesg:

[  230.521547] usb 4-1: USB disconnect, device number 2
[  241.167717] usb 4-1: new full-speed USB device number 3 using uhci_hcd
[  241.360406] usb 4-1: New USB device found, idVendor=1870, idProduct=0001
[  241.360413] usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  241.360419] usb 4-1: Product: Nexio BLK Multi-Touch NIB 190(19")
[  241.360425] usb 4-1: Manufacturer: Nexio Touch Device(BK)
[  241.363810] cdc_acm 4-1:1.0: This device cannot do calls on its own. It is not a modem.
[  241.363858] cdc_acm 4-1:1.0: ttyACM0: USB ACM device

Could anybody help me, please?

share|improve this question

1 Answer 1

I'm using Samsung ME46C (Nexio touch screen inside) with Ubuntu 12.04. Finally the touch screen worked after installing UPPD.

  1. Download 76616_linuxupdd.tgz from http://touch-base.com/download.asp
  2. Follow "GUI Installation Procedure" in http://www.touch-base.com/documentation/LinuxPlatformNotes.htm#GUIinstall

The below steps are quoted from the GUI Installation Procedure link:

Ensure you have the correct setup file to match your processor’s architecture, being 32 or 64 bit. An error will be issued if you have the incorrect setup file:

enter image description here

Installation of the driver must be performed as the "root" user. It is usually possible to "become" the root user by typing command "su root" or preceding the setup command with “kdesu” or “sudo” (as seen in above screen shot), but we have found on some systems this is not sufficient in which case you must log on at system start as root.

The main installation package is held within the compressed file called linuxupdd.tgz. Copy the file into a directory other than /opt or / such as a users home directory on the Linux system, change to that directory, then decompress it by using the command “tar zxvf linuxupdd.tgz”.

Important - Do not decompress the software in the root directory or /opt/ as the install will fail.

To install the software open a terminal window and either use “su” or “kdesu” to become the root user then type “./setup”. Alternatively type “sudo ./setup” and enter your password. This will launch the setup program: Important note: the ‘setup’ program is extracted directly into the extraction directory and is not located in the ./opt/tbupddlx subdirectory just created.

  • From the device list dialog select the touch device or, if it is a PnP device, optionally leave the PnP mechanism to pick up the device(s).
  • From the distribution list dialog select the distribution script if it is listed. Select the script that most closely matches your distribution. In no script matches select either “Other” or “Other-Legacy. E.g. If an exact match is listed, say Ubuntu Gusty Gibbon (Ubuntu 7.10), select that.
  • Install scripts can invoke question dialogs, such as ‘OK to enable USB file system’. Answer these dialogs as appropriate.

Following installation you must reboot the system for the driver to load.

If the install fails please refer to the notes in the GUI Installation Procedure link in (step 2 above) to see if there is a solution to your problem.

share|improve this answer
    
Thanks! A couple of problems though: I now get the cursor on 13.04, and multitouch isn't working. My problem before this driver was that the touch got messed up after using multiple fingers, and you had to reboot. Now it works, but only single-touch and with a cursor showing.. –  user203533 Oct 17 '13 at 10:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.