Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Live CD and installation have working network connection.

But after installing, the network connection is offline; it won't connect! No automatic configuration, aka DHCP doesn't work.

Static configuration allows it to connect to the network (so it says) but I'm unable to ping my DSL router, hence the NIC isn't working properly. It will ping the loopback and it's own static IP address and that's it. The router also doesn't see it connected to network! I've disabled IPv6, but still no luck. I've tried the command dhclient eth0, but still no luck. I've tried service network-manager restart, but still no luck. ifconfig shows static IP configuration and IPv6 disabled. My guess is the installed network driver is different from the Live CD and Installation version; how retarded is that!

Ok, seeing how I have no internet connection on this machine, how in the heck do I manually install a network driver for a dual boot Intel Mac Mini (2009 model)? I've been searching for an answer for 3 days now. I've seen the same problem numerous times posted all over the internet, but I have yet to find a solution to the problem =).

By the way, in OSX, the network functions flawlessly so it's not a hardware or network problem. Also, seeing how this OS has driver issues among other things, would it kill someone to create a GUI Device Manager that installs with the OS. It would be nice to be able to manage device drivers without going into the terminal...just a thought.

share|improve this question
    
You need to copy and paste the output of the commands that you have run and not describe the results to help us assist you further. The output of ifconfig, route, arp is needed for starters. –  Fred Thomsen May 20 '13 at 3:53

1 Answer 1

Try configuring your interfaces file:

1) Open a terminal
2) For sudo session type: sudo -i
3) Enter your password
4) Edit the file: gedit /etc/network/interfaces

You should see something like this in the file content:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

interfaces(5) file used by ifup(8) and ifdown(8)

auto lo
iface lo inet loopback
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

5) Add the eth0(Cable) or wlan0(Wireless) interface with dhcp configuration:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

DHCP config for eth0

auto eth0
iface eth0 inet dhcp
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

OR

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

DHCP config for wlan0

auto wlan0
iface wlan0 inet dhcp
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

6) Save the file and exit
7) Reboot and it should work fine if this is the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.