Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to enter a new facebook account via gnome-control-center's "Online Accounts" but it doesn't work. When I click facebook, it shows a rotating icon then firefox opens and opens a page where facebook asks me my email address and password then nothing. Nothing happends. It just redirected to this Web address:

https://www.facebook.com/connect/blank.html#_=_

It and has these words:

Success

SECURITY WARNING : Please treat the URL above as you would your password and do not share it with anyone.

Have also tried upgrading packages but still it doesn't work.

I am also using x86 version of ubuntu raring and also the problem doesn't appear on the x86_64 version of ubuntu raring.

Update: After updating my x86_64 installation of ubuntu raring the problem appears.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

I found a Workaround. Check this : https://bugs.launchpad.net/ubuntu/+source/account-plugins/+bug/1180297/comments/4.

Edit /usr/share/accounts/providers/facebook.provider

sudo gedit /usr/share/accounts/providers/facebook.provider

Put this under line 13,

<setting name="AllowedSchemes" type="as">['https','http']</setting>

Example:

This is the original /usr/share/accounts/providers/facebook.provider:

<?xml version="1.0" encoding="UTF-8"?>
<provider id="facebook">
   <name>Facebook</name>
  <icon>facebook</icon>
  <translations>account-plugins</translations>
  <domains>.*facebook\.com</domains>
  <plugin>generic-oauth</plugin>
  <template>
    <group name="auth">
      <setting name="method">oauth2</setting>
      <setting name="mechanism">user_agent</setting>
      <group name="oauth2">
        <group name="user_agent">        
          <setting name="Host">www.facebook.com</setting>
          <setting name="AuthPath">/dialog/oauth</setting>
          <setting name="RedirectUri">https://www.facebook.com/connect/login_success.html</setting>
          <setting name="Display">popup</setting>
          <setting type="as" name="Scope">['publish_stream','read_stream','status_update','user_photos','friends_photos','xmpp_login']</setting>
          <setting name="ClientId">302061903208115</setting>
        </group>
      </group>
    </group>
  </template>
</provider>

This is the modified /usr/share/accounts/providers/facebook.provider:

<?xml version="1.0" encoding="UTF-8"?>
<provider id="facebook">
   <name>Facebook</name>
  <icon>facebook</icon>
  <translations>account-plugins</translations>
  <domains>.*facebook\.com</domains>
  <plugin>generic-oauth</plugin>
  <template>
    <group name="auth">
      <setting name="method">oauth2</setting>
      <setting name="mechanism">user_agent</setting>
      <group name="oauth2">
        <group name="user_agent">      
+         <setting name="AllowedSchemes" type="as">['https','http']</setting>  
          <setting name="Host">www.facebook.com</setting>
          <setting name="AuthPath">/dialog/oauth</setting>
          <setting name="RedirectUri">https://www.facebook.com/connect/login_success.html</setting>
          <setting name="Display">popup</setting>
          <setting type="as" name="Scope">['publish_stream','read_stream','status_update','user_photos','friends_photos','xmpp_login']</setting>
          <setting name="ClientId">302061903208115</setting>
        </group>
      </group>
    </group>
  </template>
</provider>

Note: however that this exposes your desktop to some security risks, so please use it only if you are connected to a trusted network. -- Alberto Mardegan (mardy)

Source: https://bugs.launchpad.net/ubuntu/+source/gnome-control-center-signon/+bug/1180297

Update: Seems that this bug is fixed on the quantal-proposed and raring-proposed. The package is account-plugin-facebook and its version is 0.10bzr13.03.26-0ubuntu1.1

share|improve this answer
    
This doesn't work, now I can't open Online Account. –  Nur May 20 '13 at 14:09
    
Thanks a lot, this worked for me, with Ubuntu 13.04 64-bit. –  Sadi May 21 '13 at 6:22
    
Can we perhaps reduce security risks a little bit if we only include 'https' and leave out 'http' in this line to be inserted? –  Sadi May 21 '13 at 9:08
    
I do not know @Sadi because I am not a developer or a coder. I just found this comment while searching the net. Sorry... still at 14 –  user128712 May 21 '13 at 12:19
    
OK, thanks, I've posted this to the bug site. –  Sadi May 21 '13 at 12:21
add comment

protected by Community Jul 15 '13 at 4:31

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.