Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I set a different mac address in the networkmanager, but it keep the old mac address.

However, change mac work with type ifconfig hw ether ***, but it's not that I want:

I found this in /var/log/syslog:

May 19 07:14:22 j-QTH6 NetworkManager[1244]: <info> (wlan1): taking down device.
May 19 07:14:22 j-QTH6 NetworkManager[1244]: <warn> (wlan1): failed to change interface MAC address
May 19 07:14:22 j-QTH6 NetworkManager[1244]: <warn> (wlan1): failed to set MAC address to A8:35:D7:D2:4F:1A
May 19 07:14:23 j-QTH6 NetworkManager[1244]: <info> Activation (wlan1) Stage 2 of 5 (Device Configure) scheduled...
May 19 07:14:23 j-QTH6 NetworkManager[1244]: <info> Activation (wlan1) Stage 1 of 5 (Device Prepare) complete.

I also try to change another mac, still not work.

Then I tried to do the same thing in ubuntu13.04-amd64, xubuntu13.04-amd64 and ubuntu12.04LTS-amd64. I found it only work in 12.04LTS.

So is there any solution?

share|improve this question
add comment

1 Answer

In a terminal, macchanger --help, among other things, it shows me:

GNU MAC Changer
Usage: macchanger [options] device

  ...
  -m,  --mac=XX:XX:XX:XX:XX:XX
       --mac XX:XX:XX:XX:XX:XX  Set the MAC XX:XX:XX:XX:XX:XX

So, macchanger is a good Linux utility for changing the MAC address for network interfaces.

Here is how I changed my MAC:

macchanger

To use macchanger and airmon-ng, I think you need to have installed aircrack-ng. To install it, run in a terminal:

sudo apt-get install aircrack-ng
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.