Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Firstly, I saw topics such as 'How to install manually a software ...' but my problem doesn't solved!

I've downloaded Scilab 5.4.1 from official website. And i extract '.tar.gz' file in :

/home/scilab-5.4.1

directory. I tried below commands but get several errors:

$ cd scalib-5.4.1
$ configure        @1
$ make             @2
$ make install     @3

Termianl Messages :

@1: configure: command not found

@2: make: * No targets specified and no makefile found. Stop.

@3: make: * No rule to make target `install'. Stop.

I tried following Terminal-Command to run that :

$ cd scilab-5.4.1
$ cd bin
$ scilab

Termianl message:

The program 'scilab' is currently not installed. You can install it by typing: sudo apt-get install scilab

share|improve this question
    
Does't change ! same error :( –  Hamed Kamrava May 19 '13 at 12:29
    
I don't understand your mean ! Because i'm newbie :) usr/local/src/ is empty! There is no configure directory ! –  Hamed Kamrava May 19 '13 at 12:51
    
Why dont you install it with sudo apt-get install scilab? –  thefourtheye May 19 '13 at 13:17
    
Ubuntu repository Scilab is't update :( Ver 3.5.5 –  Hamed Kamrava May 19 '13 at 13:20
    
Any suggestion.. ? –  Hamed Kamrava May 19 '13 at 16:29
show 3 more comments

3 Answers 3

up vote 2 down vote accepted

Ok, I just tried installing it, an it worked OK. Here what I did: To install, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get install scilab

After the installation was done, I searched for scilab in dash, and clicked on it

enter image description here

After I clicked on it, it opened, and I checked the version, and it was 5.4.1

Hope that helps.

enter image description here

share|improve this answer
add comment

You can also just download the version for linux and simply click the binary in scilab/bin/scilab. It should work.

share|improve this answer
add comment

Your terminal command should work, but with the following change:

$ cd scilab-5.4.1
$ cd bin
$ ./scilab

Note the "dot-slash" before "scilab". "Dot" is the current working directory. Your shell was looking for scilab in all of the directories in your PATH environment variable, and not finding it, suggested that you needed to install the package. Do:

echo $PATH

on the command line and you will see which directories are searched.

This is a really common mistake - after a while, including the dot-slash will be second nature. Note you can also include the path structure in the command line launch:

$ cd scilab-5.4.1
$ ./bin/scilab

Hope this helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.