Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In the past I was able to get my webcam working with Skype using the fix described here:

Skype video not working after upgrade from 11.10 to 12.04

It meant starting skype with:

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype

This worked well on Ubuntu 12.04, but doesn't work anymore on Ubuntu 13.04. Probably because the executable file in /usr/bin/skype is replaced by a script that says:

#!/bin/sh
#
# Tip in https://launchpad.net/bugs/1002187, comment #31
#
# Bug filed against Skype: https://jira.skype.com/browse/SCL-980
#
export LD_PRELOAD="/usr/lib/i386-linux-gnu/mesa/libGL.so.1${LD_PRELOAD:+:}$LD_PRELOAD"
exec /usr/lib/skype/skype "$@"

It seems that this script is needed to work around a bug to start Skype on Ubuntu 13.04 but it is probably also overriding my own webcam fix and I guess that's the reason it is not working anymore.

So I need to add my webcam fix to this script, but I have a hard time finding out how? Any help with this?

share|improve this question
    
try out this link askubuntu.com/questions/300060/skype-no-video-in-13-04 –  user161811 May 31 '13 at 0:24

2 Answers 2

Just fixed it! There is a new version of Skype, version 4.2 You can install it from the Skype website. They didn't fix the long standing issues that a lot of people have with their webcams, but it seems they did fix the segfaulting issue. So /usr/bin/skype is not a script with some LD_PRELOAD magic anymore but an executable file.

This makes the webcam fix from: Skype video not working after upgrade from 11.10 to 12.04 also working again. Great!

share|improve this answer

I fixed this by creating the file /usr/local/bin/skype with the following contents:

#!/bin/bash
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/lib/skype/skype

And making it executable:

sudo chmod a+x /usr/local/bin/skype

I had a fresh Raring install so I also needed to install the 32bit libs.

sudo apt-get install ia32-libs
share|improve this answer
1  
Nice that this fix works for you on Ubuntu 13.04! But it isn't working for me, because Skype crashes with a segmentation fault. Most likely because of bug bugs.launchpad.net/ubuntu/+source/skype/+bug/1002187 That's why the package maintainer of Skype replaced the executable in /usr/bin/skype with a script that does some LD_PRELOAD magic and I need that fix for Skype to start, but I would also like to get my camera working. –  joris May 21 '13 at 11:18
    
Right, yeah, I must not be affected by the other bug. –  gacrux May 21 '13 at 23:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.