Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently decided to migrate to Ubuntu after issues with working in Windows and Remote Desktop access.

I made a bootable USB flash drive with Ubuntu 13.04-amd64 today and proceeded to install on an empty 250 GB HDD. The install went was worry free, however after rebooting all I get is a black screen with a white cursor flashing.

I looked around the internet and thought maybe GRUB did not install correctly. For reference, my system specifications are below:

Intel i3 2100, Asus P8Z68-V LE, ATi Radeon HD 6850, WD Black 640 + Intel 40 GB SSD (Windows 7), Seagate 1.5 TB (NTFS data), WD 250 GB (Ubuntu)

I tried sudo grub-install --root-directory=/mnt /dev/sdd1 and I get the error "Path /mnt/boot/grub is not readable by GRUB on boot. Installation is impossible. Aborting".

Does anyone have any thoughts?

Thanks!

share|improve this question
add comment

3 Answers 3

To re-iterate, Windows 7 was booting completely fine post install so the issue was not NTFS. I managed to fix the issue and everything is working peachy smooth. My solution is detailed below for anyone who has similar EFI booting problems.

Drive were mounted as:

i. SDA: Mint UEFI install flash drive ii. SDB: Intel SSD used in SRT caching iv. SDC: 1.5 TB NTFS data drive v. SDD: 250 GB WD Linux install vi. SDE: 640 GB WD drive with Windows 7

  1. Start UEFI USB install
  2. Delete the EFI partition on SDC
  3. Delete partition table on SDD
  4. Manually create a 200 MB EFI boot partition at sector 0 on SDD
  5. Create 237 GB EXT 4 partition on SDD
  6. Create 13 GB Swap partition on SDD
  7. Install Linux to SDD
  8. Reboot and set UEFI: linuxmint as default in the bios

I am pleased to say everything is working flawlessly now including the proprietary AMD Catalyst drivers, AMD Overdrive, Steam, Skype, Creative THX external sound card, MX518, Sublime Text 2, LaTeX, etc. This is by far the most complete, out-of-the-box install I have ever done. Once I sorted out the booting issues it was even smoother than Windows.

Cheers!

share|improve this answer
add comment

Do not install grub in a partition. Grub should be installed in the MBR of the first HDD. /dev/sda (not /dev/sda1 or /dev/sda2 .. etc).

You can use boot-repair to fix the grub problem (if this is the actual problem.)

share|improve this answer
    
I do not agree that that is a firm rule. This case seems to be a dual boot situation. In which case it is possible (and maybe even wise) to let Windows have the MBR and insert a pointer to the Ubuntu boot partition in the Windows boot menu. –  matv1 May 19 '13 at 0:46
    
Thanks for the advice guys. Do you know how to go about doing it? Would I accomplish this with EasyBCD? –  unhappymeal May 19 '13 at 1:07
    
Yes I believe you will be able to do it with EasyBCD. I have done it like that many times(except I always had Windows and Ubuntu on the same HD) but EasyBCD should be able to handle multiple drives as well. Check out the manual: neosmart.net/wiki/display/EBCD/Linux –  matv1 May 19 '13 at 1:51
    
I tried using boot-repair and it was unable to successfully repair it. The pastebin link is below: paste.ubuntu.com/5679077 Thoughts? –  unhappymeal May 19 '13 at 1:59
    
That is indeed a bit of a mess :) Have you tried using the bootrepair option from windows installations disk? I think its called Bootrec.exe. That way you can regain access to the Windows installation and after that retry the Ubuntu install –  matv1 May 20 '13 at 0:03
show 1 more comment

The first part of your problem is that you are running an AMD version of Ubuntu on an Intel system. This will not work at all, Why? becuse of the way AMD makes there prossessors is compleately diffrent for the way Intel makes there prossessors. This isn't MicroCrap they have to talor the kernal to the type of prossesor that you are useing.. the only Intel version of ubuntu 13.04 that I found off of the ubuntu web site is only a 32 bit version. They have not come out with a 64 bit version for Intel yet. You can check it out here. I say yet becuse we are talking about the NEWEST version of Ubuntu that came out 2 - 3 weeks ago.

BTW: UEIF is realy a problem if you have preinstalled windows 8 system not windows 7 ... My Desktop Runs Windows 7 and Ubuntu 13.04 just fine and it has UEIF on the BIOs... IF you buy a PC that has windows 8 preinstalled from the manufacture thats when you will have the bigest problems becuse the activation key to windows 8 is hard coded into the bios.. another resion why micrsoft needs to be shutdown all together.

share|improve this answer
    
Errr...I thought AMD64 referred to the x86-64 instruction set that AMD developed and was not processor specific. To answer your question, I installed Windows 7 myself using UEFI. The issue was the Ubuntu installer placed two UEFI boot partitions on the drive and flagged them both in GRUB. The solution is outlined above. So none of my issues have anything to do with Microsoft or Windows... –  unhappymeal May 20 '13 at 15:52
    
@unhappymeal You are completely correct, amd64 just means 64bit, this guy has no idea what he's on about. –  handuel May 20 '13 at 15:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.