Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Neverwinter Nights on this very machine while running 12.10, following the instructions here. Since upgrading to 13.04, nwn hangs when I run it. This is a strace log file generated by my modified startup script. I have to kill nwn and kill -9 nwmain because it never unloads. No window ever opens. If I'm reading the log correctly, it doesn't find some libraries and then segfaults and hangs.

I tried first with my unchanged installation created under 12.10, then reinstalled fresh from the DVD but with no change. I seem to be having exactly the same problem as in the "Neverwinter Nights does not run in 12.10" question on here (not enough rep to link), but that was never resolved either. Googling has yielded no similar reports for 13.04.

Of the libraries I've tried to manually verify the existence of, the only file I couldn't actually find is ld.so. manpages.ubuntu.com doesn't have an entry for it in 13.04, interestingly. Unfortunately I don't know enough about how libraries work under linux to know if this has any bearing on my problem or is maybe just another xorg.conf, which no longer exists in its original form in Ubuntu either.

I'm happy to provide any additional logs or information and I'm no stranger to the terminal.

Vital stats:
Xubuntu 13.04 x86 on an ASUS X53E laptop
Intel Core i5-2450M @ 2.50GHz
4GB RAM
Intel integrated onboard graphics (if model is important, I'll have to reboot into Win8 to check)

share|improve this question
    
Lot of text but there is nothing to respond on for me ... can you include what is shown on command line when you start it? ld.so does exist: manpages.ubuntu.com/manpages/quantal/man8/ld.so.8.html You can try and use the 12.10 version ;) –  Rinzwind May 18 '13 at 20:27
    
Nothing shows when I start without nwmovies. With the patch I get this before it hangs and I have to kill it. Re: ld.so, that link is to the quantal page (12.10). If you hit 13.04 at the top it tries raring, redirects to a search, and kicks you back to 12.10. –  David May 18 '13 at 20:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.