Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu to dual boot on my MacBook. However, the brightness feature does not work! It only happened after I changed the display driver. I am using Ubuntu 13.04

lspci:

00:00.0 Host bridge: NVIDIA Corporation MCP79 Host Bridge (rev b1)
00:00.1 RAM memory: NVIDIA Corporation MCP79 Memory Controller (rev b1)
00:03.0 ISA bridge: NVIDIA Corporation MCP79 LPC Bridge (rev b3)
00:03.1 RAM memory: NVIDIA Corporation MCP79 Memory Controller (rev b1)
00:03.2 SMBus: NVIDIA Corporation MCP79 SMBus (rev b1)
00:03.3 RAM memory: NVIDIA Corporation MCP79 Memory Controller (rev b1)
00:03.4 RAM memory: NVIDIA Corporation MCP79 Memory Controller (rev b1)
00:03.5 Co-processor: NVIDIA Corporation MCP79 Co-processor (rev b1)
00:04.0 USB controller: NVIDIA Corporation MCP79 OHCI USB 1.1 Controller (rev b1)
00:04.1 USB controller: NVIDIA Corporation MCP79 EHCI USB 2.0 Controller (rev b1)
00:06.0 USB controller: NVIDIA Corporation MCP79 OHCI USB 1.1 Controller (rev b1)
00:06.1 USB controller: NVIDIA Corporation MCP79 EHCI USB 2.0 Controller (rev b1)
00:08.0 Audio device: NVIDIA Corporation MCP79 High Definition Audio (rev b1)
00:09.0 PCI bridge: NVIDIA Corporation MCP79 PCI Bridge (rev b1)
00:0a.0 Ethernet controller: NVIDIA Corporation MCP79 Ethernet (rev b1)
00:0b.0 IDE interface: NVIDIA Corporation MCP79 SATA Controller (rev b1)
00:10.0 PCI bridge: NVIDIA Corporation MCP79 PCI Express Bridge (rev b1)
00:15.0 PCI bridge: NVIDIA Corporation MCP79 PCI Express Bridge (rev b1)
02:00.0 VGA compatible controller: NVIDIA Corporation C79 [GeForce 9400M] (rev b1)
03:00.0 Network controller: Broadcom Corporation BCM43224 802.11a/b/g/n (rev 01)

`jockey-text

kmod:nvidia_173 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
kmod:nvidia_310 - nvidia_310 (Proprietary, Enabled, Not in use)
kmod:nvidia_310_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
kmod:wl - Broadcom STA wireless driver (Proprietary, Enabled, In use) [auto-install]
kmod:nvidia_313_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
kmod:nvidia_304_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
kmod:nvidia_304 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)

Strangely the Nvidia driver I am using is not showing up as in use from the output above. It is the NVIDIA binary Xorg driver, kernel module and VDAPU library from nvidia-310

How do I fix the brightness on the computer?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Install this deb:

https://github.com/guillaumezin/nvidiabl/raw/master/install/deb/nvidiabl-dkms_0.81_all.deb

Load the module:

sudo modprobe nvidiabl

Paste this into your /etc/X11/xorg.conf:

Section "Device"
   Identifier     "Device0"
   Driver         "nvidia"
   VendorName     "NVIDIA Corporation"
   Option         "RegistryDwords" "EnableBrightnessControl=1"
   Option         "NoLogo" "True"
   Option         "AllowGLXWithComposite" "true"
   Option         "DPMS" "1"
   Option         "OnDemandVBlankInterrupts" "1"
   Option         "RegistryDwords" "EnableBrightnessControl=1; PowerMizerEnable=0x1;    PerfLevelSrc=0x2233;PowerMizerDefault=0x3"
EndSection

Now the brightness control should work.

share|improve this answer
    
That didn't work... is there any special procedure I need to follow? –  elder4222 May 20 '13 at 23:25
    
Hm. not sure. I added my xorg.conf section. Maybe this helps? –  user2114948 May 22 '13 at 17:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.