Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am writing a shell script that will execute some application for a specific mime type, and it does it correctly, but when I have echo in my shell script, I dont see any terminal with the echoes message, is there any way to make the terminal show ?

share|improve this question
1  
How do you invoke the shell script? –  thefourtheye May 19 '13 at 3:07

1 Answer 1

If you're planning for this script to always execute in a windowed environment, and these messages are only used for rare errors, consider using xmessage or gmessage instead of echo. This will bring up a new window with the message, which the user can click to dismiss.

On the other hand, if the messages are common or frequent, you might want to always run your entire script inside a new terminal window for that mime type. Instead of configuring it to run your script, try running this:

gnome-terminal -e "path to your script"

I assume you also need to pass the name of the file to open to the script, but I'm not sure how that parameter is encoded in the context where you're doing this. It might be as simple as putting something like $* or %s at the right spot inside the quotes.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.