Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was installing NVM using this command:

curl https://raw.github.com/creationix/nvm/master/install.sh | sh

as explained in the github page https://github.com/creationix/nvm

It didn't work, so I tried changing the line in ~/profile

and not I cannot login to my user !

when I try a wrong password I get a wrong password message. but, when I try the real password, It looks like it is logining and then just comming back to the login page again (no bad password message) - Please help !

I'm few weeks into ubuntu/linux, and it worked quite good until now. it's ubuntu 13.04.

thanks again.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Regarding the reason why you are now unable to log in, that is most likely due to the edit you made to ~/.profile; your login shell is trying to execute an invalid command (because the NVM install failed) and quitting. To repair this, you will need to undo that edit to your ~/.profile somehow. The easiest way is probably to hold shift during a reboot, select Recovery Mode from the menu, drop to a root shell prompt, then edit the file and reboot again.

As for why the original command failed, I would guess that your system doesn't have git installed (the github page says "(requires Git)"). Once your system is back in working order, try this before attempting to install NVM again:

sudo apt-get install git
share|improve this answer
    
I see. will try to fix .profile the way you said. About git, I did had it installed, but installed it from Ubuntu software center, not using apt-get. is that a problem ? –  Daniel May 18 '13 at 18:27
    
@Daniel, no, Software Center is just as good as apt-get for this, so the NVM failure is likely due to something else. Good luck with your system recovery. –  Paul May 18 '13 at 18:30
    
about git, I see, next time i'll just install node no nvm. about recovery, I tried to edit ".profile" using NANO from Recovery mode - it's says it's "read only". looking to change that. thanks alot Paul. –  Daniel May 18 '13 at 18:47
    
System recovery - succeed (-: Thanks for the help. In the end I used ctr+alt+f1 --> nano .profile –  Daniel May 18 '13 at 19:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.