Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just upgraded my Ubuntu Server to 13.04, and the existing and working fstab configuration for a cifs mount is failing with the generic -22 error (invalid argument):

12:38 PM wesley at wsrv cwd ~
$ sudo mount /Volumes/Storage/
mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

This is the line at /etc/fstab:

//10.0.0.1/Storage      /Volumes/Storage        cifs    uid=1000,gid=1000,user=wesley,password=[hidden]       0       0

The server is an Airport Extreme, other machines connect to it fine currently.

This was working fine on 12.10.

share|improve this question
    
Can you please execute the mount command with --verbose –  thefourtheye May 19 '13 at 3:25

2 Answers 2

up vote 0 down vote accepted

I have found a solution. Add the option sec=ntlm - this works both in a manual mount and from fstab

The fstab entry is now -

# Network USB Drive - ie the USB Flash Drive connected to the Modem
//192.168.0.1/USB /home/user/USB cifs sec=ntlm,uid=1000,gid=1000,guest,_netdev 0 0

Based with Thanks from http://ubuntuforums.org/showthread.php?t=2139090

share|improve this answer

Same issue here... sec option didn't help me. I was able to temporarily access the data with:

smbclient //SERVER_ADDRESS -U USER%PASS 

I was also able to ping the IP and Name successfully!!!

mount -a returns Unable to find suitable address. mount.cifs //SERVER /DESTINATION -o ..... receives same error as yours.

I'll be keeping an eye on this in hopes it's solved; maybe what I've posted helps?

Good luck

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.