Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a old Athlon X2 based system with an attached floppy drive. I had some old floppies which are now safely backed up on CD's.

Is there a way to simply disable the floppy drive, so that it wont be accessed in any way by the OS? I would not have bothered, but ubuntu seems to continually access the drive, and it is annoyingly noisy. Thanks in advance.

share|improve this question
    
The above procedure eliminates the message, but unfortunatelly it stops the capability of mounting the floppy when needed. The error message only happen on Linux Mint MATE, while Linux Mint CINNAMON does not have the problem. The question is what is the difference and who is trying to mount the floppy automatically. The solution would be to eliminate the automatic mount not eliminating the device. I have not seen the right answer yet... F.G –  user140582 Mar 15 '13 at 16:41

3 Answers 3

up vote 11 down vote accepted

A more complicated answer as I have a laptop with no floppy drive.

  1. Edit /etc/fstab to remove reference to floppy.

  2. Edit /etc/modprobe.d/blacklist and add this line at the end:

    install floppy /bin/false
    
  3. Run: sudo update-initramfs -u

  4. Run: sudo update-grub

  5. Reboot.

share|improve this answer
    
Or you can go into the bios and shut it off. If you don't actually have a floppy, you shouldn't configure your bios to think you do. –  psusi Mar 9 '11 at 20:13
    
Thanks for the answer. Unfortunately I have searched everywhere in the bios and there is no way of disabling it from there, and i do not want to remove it, coz i still have some old floppies lying around which i may need in the future, so temporarily disabling it is my only option. –  tinhed Mar 10 '11 at 6:36

Go into the bios and shut it off.

share|improve this answer
    
Another solution: Open your case and remove the floppy cable. –  FUZxxl Mar 9 '11 at 19:49
    
@FUZxxl: that will make matters worse since it will still think there is a drive and will try to use it. –  psusi Mar 9 '11 at 19:51
    
Disable floppy in bios works well, simple and good solution. thanks. –  DUKE Dec 11 at 14:24

I would do a combination of both previous solutions and more.

First, disable floppy from both /etc/fstab and /etc/modprobe.d/backlist, sudo update-initramfs -u and sudo update-grub. The drive would be disabled at the OS level.

Second, I would disable the floppy drive on the BIOS settings, if possible. Most BIOSes will let you disable this drive. Look at the keys at very beginning, just after you power the computer on. The drive would then be disabled at the BIOS level.

Third, I would then (and only then) actually disconnect the floppy drive internally, both data and power. The drive is just GONE !!!

share|improve this answer

protected by Community Mar 15 '13 at 17:48

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.