Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I used Windows (sorry for bringing it up,) I could specify in the sound control menu which programs I wanted playing through which speakers. For example, I could have Skype playing through my headphones, while having a game playing sound through my loudspeakers.

Now, I know that this is possible using some virtual output options, but I have another problem: on Linux, whether I select "Headphones" or "Analog Output", the sound goes through my headphones if they're plugged in, and the only way to use my speakers is by unplugging them. I'm using the headphone port on the front of my case, and the audio port on the back of my motherboard, and I don't have a dedicated sound card, so I know this might be a hardware issue. However, I know it's possible, because I was able to do it through Windows.

A few more details: I'm currently using PulseAduio, but I'd be happy to ditch it. I'm using Kubuntu. Finally, I want to clarify, as I've seen some people answer others incorrectly due to a lack of understanding: I do NOT want to mirror my sound across both devices. I want SOME applications to play through my speakers, and other apps to play through my headphones.

share|improve this question

1 Answer 1

Click on the sound indicator and go to settings. Then on the application tab there is a per application setting for output and input device. It it doesn't have it there then you can looking in pavucontrol (you may have to install it). It's a bit more complicated to use but works quite well.

share|improve this answer
    
Thank you for your help. I already have pavucontrol installed. I went back to check again, and I now feel the need to elaborate more. There is only one device listed under the "Output Devices" tab. Under that, there are two "ports" I can select using a drop-down box. One is "headphones"; the other is "analog output." This would lead me to believe that I need another sound card to accomplish my goal, but once again, I succeeded in doing this under Windows. If I can get those two ports split into separate output devices, I believe I know how to select the per-application settings. –  jacobgkau May 18 '13 at 4:34
    
It's most likly differences in drivers but give this a try. It may work for you. –  coteyr May 18 '13 at 5:01
    
Alright, there's some progress. Now, when I select the "headphones" port, audio comes only through my speakers, and when I select the "Analog Output" port, sound comes through both my speakers and my headphones. So now I need to keep the speakers from playing through "Analog Output," and I also need to separate the ports into different outputs. –  jacobgkau May 18 '13 at 16:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.