Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Variations of this problem certainly seem to be common, but I'm not not seeing a recent solution for my case: I'm running Ubuntu 13.04, uname -r = 3.8.0-21-generic lspci = 02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)

The wifi network connection is relatively slow, but more seriously, repeatedly drops completely every few minutes. It usually recovers in a minute or so, but then drops again in 1-3 minutes. Running Windows 8 (ugh) on the same system, the connection never drops. Some of the solutions proposed, involve compiling/installing a new driver from Realtek - I'm really not comfortable doing that. Another suggested adding a /etc/modprobe.d/rtl8192.conf file containing a "options rtl8192ce ips=0 debug=2" line. I tried that - no effect. Another solution proposed deleting the network manager and installing something called "wicd". I haven't tried that yet, wondering, if "wicd" didn't help/work, could I use apt-get to purge it and re-install the network manager to get back to where I am?

Suggestions?

share|improve this question
    
Have you set the ipv6 to "ignore"? A friend found wicd reconnected much faster than networkmanager, so was more usable, but still had disconnects. –  ubfan1 May 17 '13 at 21:16
    
For reasons unknown, the disconnects are much less frequent today even before disabling Ipv6. I disabled Ipv6 using the instructions in link and the speed is still quite slow - about half what I see with an older notebook running Ubuntu 12.04, even though my router and new notebook are 802.11 n enabled and the old notebook is not. –  Larry McMains May 19 '13 at 13:21
    
Check for errors and signal strengths with ifconfig, iwconfig, and sudo iwlist scan. W8 may handle errors differently, e.g. maybe just ignoring them rather than trying to reconnect for a better connection. –  ubfan1 May 19 '13 at 17:32
    
I believe I managed to disable 802.11n and my connection speeds are now comparable to what I see with my old laptop running Ubuntu 12.04. The connection drops continue. I compared the quality and error data from ifconfig, iwconfig, iwlist scan to what I see on the old laptop, they're similar and seem "OK". I guess I can live with this (and hope that a future Ubuntu update fixes the problem). I'd hoped that a new laptop and new router that supported "n" would yield better performance. –  Larry McMains May 19 '13 at 23:34
add comment

2 Answers

Based on this blog post and my own attempts to solve the problem (though I haven't run it for long, so YMMV), you can try the following:

Firstly, download the manufacturer drivers. You'll need to navigate through the tree to find the right one (in an attempt to keep this post somewhat future proof). Certainly, for me to get the RTL8188CE driver, I navigated to the IEEE 802.11b/g/n single-chip option, and then just ticked the relevant boxes.

Next untar the sources and attempt to install with sudo make, sudo make install. The sources I downloaded required some modification. It seems that the __devinit macros were removed from the kernel in 3.8, so I had to remove __devinit from pci.h and pci.c and also remove __devinitdata from each sw.c in each of the driver directories (that is, I removed the single word in the function definition). After that, make and make install worked just fine.

I think that should be sufficient as it seems to overwrite the previously installed rtl8192ce.ko module, so it should just work with the new driver on reboot.

I expect it would be necessary to redo this after each kernel upgrade (assuming you still need it of course!).

share|improve this answer
add comment

You mention that you aren't comfortable compiling and installing a driver, but unfortunately you can't do this without that. Fortunately, because of the pain I went through personally, I have made it as easy as possible for you. I fixed the compile issues on 13.04 with the RTL8188CE driver and put detailed instructions for install up on my Git Hub.

This version fixes the compile error and also fixes the hard-coded Tx Power value that was set to 22 dBm.

First install Git and build dependencies:

sudo apt-get install git
apt-get install gcc build-essential linux-headers-generic linux-headers-`uname -r`

Then clone the repo. I like to make a directory in my home folder and put it there:

cd ~
mkdir gitclone && cd gitclone
git clone https://github.com/FreedomBen/rtl8188ce-linux-driver/blob/master/README.md
cd rtl8188ce-linux-driver

Then follow the instructions in README.md

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.