Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

in System settings >> Online accounts when i add facebook account it redirects me to the browser and opens a webpage in the photo below and do nothing after that

any help ??Photo

share|improve this question
    
Try open the web page in Firefox or change the default web browser to Firefox. TQ. –  Shaharil Ahmad May 17 '13 at 17:11
    
i did it on firefox , chrome and chromium –  Abo Jihad Bazoka May 17 '13 at 17:34
    
this happened to me, using firefox and empathy. –  lapega May 20 '13 at 13:19

3 Answers 3

up vote 2 down vote accepted

One line command fix following sallp previous answer (copy paste in terminal):

sudo sed -i.bak "/<setting name=\"ClientId\">/a\          <setting name=\"AllowedSchemes\" type=\"as\">\['https','http'\]<\/setting>" /usr/share/accounts/providers/facebook.provider

If it does not work for you, you can still rollback to the previous version of the file by using the backup with:

sudo mv /usr/share/accounts/providers/facebook.provider.bak /usr/share/accounts/providers/facebook.provider

Hope it'll help!

share|improve this answer

I'd like to chime in on the issue in order to add clarity. I'm reiterating the discussion from this ubuntu forum post: http://ubuntuforums.org/showthread.php?t=2146595

The problem that everyone is happening is due to the Facebook 'Secure Browsing' option. This requires that Facebook logins and connections use HTTPS, instead of HTTP (secure HTTP vs normal HTTP). By default, I believe online accounts is using HTTP, so this just won't work.

Because of this, we have a couple of options.

Option 1 (Insecure Solution): Disable Facebook Secure browsing through the security interface on Facebook.com. This will disable HTTPS defaults on ALL of your Facebook pages on ALL devices, e.g. cell phones, other computers, etc. This works, but it is not the ideal solution.

Option 2 (Right Way): We can simply request that online accounts just use an HTTPS connection, instead of an HTTP connection. To do this, we can use Derek Karpinski's previous advice (quoted below). This is essentially telling Online Accounts to try both HTTP and HTTPS. Since Facebook needs HTTPS, this is what we want. After doing his steps below, delete the Ubuntu app on Facebook (if you had previously tried and failed to add it), log out of Facebook, and close Online Accounts. You actually don't need to restart your computer, just close Online Accounts. Re-open Online Accounts and try again. and things should work fine!

This is how you fix it, run this command in a terminal:

gksudo gedit /usr/share/accounts/providers/facebook.provider

It will open text editor. The file in question is the facebook account profile. Add this line:

<setting name="AllowedSchemes" type="as">['https','http']</setting>

right after this line:

<group name="user_agent">

Save the file and close the text editor. You will now be able to properly enter your facebook credentials from the online accounts panel.

share|improve this answer

I found the answer here https://bugs.launchpad.net/ubuntu/+source/gnome-control-center-signon/+bug/1180297 do is gksu gedit /usr/share/accounts/providers/facebook.provider

add < setting name="AllowedSchemes" type="as">['https','http'] with the others settings remove the space after < and save it worked for me but the guy who posted it said that it exposes your desktop to some security risks

share|improve this answer
    
the link is valid –  Abo Jihad Bazoka May 20 '13 at 20:52
    
sallp the link you provided is invalid, you may were trying to link to a comment that were deleted, any way you guys can still use this one bugs.launchpad.net/ubuntu/+source/gnome-control-center-signon/…. –  Zignd Jun 1 '13 at 13:48

protected by Community Jun 14 '13 at 14:32

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.