Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm sorry, this is quite a specific and esoteric question, but I thought if anyone could help...

Well, anyway, last night I used ls to look at a directory and noticed some junk hidden files I didn't want. So, unthinkingly, I ran rm ./.* to clear them. Unfortunately, I was still in ~. Well, you can imagine.

Happily this has had very few adverse effects, as it obviously didn't delete any directories, but it seems to have deleted a LaTeX config file or something.

I really have no idea what I've accidentally gotten rid of, but I had to reinstall texlive, just to be able to run pdflatex and xelatex and whilst they do now work, it's having trouble finding packages, which are definitely present in /usr/local/texlive/2011/texmf-dist/tex/latex/

If I move the appropriate .sty files from here, then I have no problems. But, as you can imagine, apart from the fact that this isn't a very satisfactory solution, I also make extensive use of the latest versions of the fontspec package, which, sadly, is dependent on a lot of other packages and files that don't seem to come with apt-get's verion of texlive.

So, my question to you is: do you know of the hidden file which I might have deleted (and which I need to put back) that could be causing this? Or, at least, is there a simpler fix than 'rejigging' the entire file system?

share|improve this question
1  
I have TexLive installed and I have no obvious TeXLive hidden files directly under my home directory. The only thing I can think of might be .profile or .bashrc. –  SMeznaric May 17 '13 at 13:18
    
Thanks for having a look for me :) At the moment I seem to have, one way or another, got things working again. However, the covington package, has had to be copied into ~/texmf/tex/latex/ so that it can be found and there are a few packages behaving differently. For example, I no longer have access to \textsubscript{} without manually loading fixltx2e which I didn't have to do before and I have to load color as well, which - in some files, I didn't have to do. I think, in short, that one of my packages must have loaded these for me, so - presumably - there's been a version reversion. –  Au101 May 17 '13 at 13:46

1 Answer 1

The only occasion that TeXlive has been installed in /usr/local/texlive is when I have done a manual install. That is, I've gone to www.tug.org, downloaded the Linux binary, etc.

If I use apt-get install texlive (or Ubuntu Software Center), TeXlive ends up in /usr/share by default.

So if you didn't do anything different from this two options, I guess that the problem is:

  1. You did a manual install (via www.tug.org). For this to work, the installer created hidden files in your home directory, which you accidentally erased.
  2. Then you installed TeXlive via apt-get or Ubuntu Software Center. Notice that (unless you've installed the texlive-full package) you won't have installed all the packages you might need.

So even if you have the packages you need installed in /usr/local/texlive, the installation via apt-get only can see the packages installed in /usr/share.

My recommendation is to install texlive-full or even better:

sudo apt-get install texlive texlive-latex-extra cm-super

if you don't need "everything"). After that you might consider uninstalling the TeXlive installed manually in /usr/local/texlive (I'm not sure right now if you can directly sudo rm -R /usr/local/texlive or if there is an uninstaller included somewhere in /usr/local/texlive).

share|improve this answer
    
I think that's a very good call. I've done that, and I think I now have two texlive installations, which is a little bit inelegant, but no matter. Everything I need right now seems to be working. I suppose, in time, I might found out that some functionality's gone missing, but I can reinstall packages when I find out I've lost them. Although, the texlive install in /usr/share is a lot lighter and it seems odd having LaTeX files all over the place, especially as I have a ~/texmf/ directory too. Is there no way to just get it to go back to using the files in /usr/local/texlive? –  Au101 May 17 '13 at 19:01
    
You might want to try and get the files you erased from www.tug.org, I guess. I mean they must have been 'quite default' files so if you google for them you might find them. Then just copy these files to your home folder and it might work. Also TeXlive (in /usr/local) should have some tool to recreate these files you could try googling about that too. –  edwin May 17 '13 at 20:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.