Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have 13.04 64-bit on my Dell M6700. Wired ethernet worked for a while, but now stopped working.

As an extra information, the ethernet works through the docking station (port replicator), but not via the plug on the back of the laptop. I have checked that it works with win7, so it is not a hw problem.

The issue is present with 3.8.0-19 kernel, but it is not present on 3.8.0-16 kernel. The exact problem is that the kernel simply does not see that a cable is plugged in, i.e., nothing goes into syslog or dmesg.

More details:

fery@fery-M6700:~$ lspci |grep Eth
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)

The driver is the e1000e module.

fery@fery-M6700:~$ cat /proc/version
Linux version 3.8.0-19-generic (buildd@allspice) (gcc version 4.7.3 (Ubuntu/Linaro 4.7.3-1ubuntu1) ) #30-Ubuntu SMP Wed May 1 16:35:23 UTC 2013

Is this the right place to ask this problem? If not, where should I go?

Thanks for help.

share|improve this question
add comment

1 Answer

I had a similar problem on my Dell Latitude E6520. The following fix worked for me:

echo on | sudo tee /sys/class/net/eth0/device/power/control

I found the solution here: http://www.kubuntuforums.net/showthread.php?62825-Ringtail-not-working-with-Intel-NIC

Good luck!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.