Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I posted this question after tried solutions from google and stackoverflow. I am using ubuntu 12.04.

I installed ldap and slapd in my machine. On installation , it prompted for admin password.

After installation , I tried to add an kerberos schema using this below command,

ldapadd  -x -D cn=admin,cn=config -W -f /tmp/cn\=kerberos.ldif

It throws an error

ldap_bind: Invalid credentials (49)

I can able to use this command with my admin password.

ldapadd  -x -D "cn=admin,dc=zmedia,dc=ultrasound,dc=com" -f tree.ldif  -W

tree.ldif

#Sample LDAP File


#users

dn: ou=users,dc=zmedia,dc=ultrasound,dc=com
objectClass: organizationalUnit
ou: users

#groups

dn: ou=groups,dc=zmedia,dc=ultrasound,dc=com
objectClass: organizationalUnit
ou: groups

I know , I gave correct password. But , I dont know why it fails?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.