Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to get my Brother MFC-6890 to work as a scanner under 12.04, but am already stumped at Step 5 in the Brother instructions

The suggested command line:

brsaneconfig3 -a name=SCANNER model=MFC-6890CDW ip=192.168.1.90

produces error messages varying from:

Syntax error: Unterminated quoted string

to

cannot execute binary file

The printer is successfully configured and working as a CUPS printer.

How can I proceed?

P.S. This is too much for a comment, so I am adding a (lack of) progress report here:

Thanks for the tips, but I still get the same errors after reinstalling.

During package installation, I get the warning "package architecture (amd64) does not match system (i386)", even though I have an AMD x64 system (with 64 bit Ubuntu). This seems to be a known problem, and at least one reason why "--force-all" is recommended.

Thanks to this parameter, the installation reports no errors.
However brsaneconfig3 still reports "Syntax error: Unterminated quoted string" when I use the command line with quotes as you recommend above, even if I execute it from the directory (/usr/local/Brother/sane) where brsaneconfig3 resides.

The ls command you recommend presents the same results that you get (showing the same symlink definition), but if I try "brsaneconfig3 -?", I get "bash: /usr/bin/brsaneconfig3: cannot execute binary file". brsaneconfig3 in /usr/bin is also a symlink to '/usr/local/Brother/sane/brsaneconfig3'. If I change to /usr/local/Brother/sane/ and do 'file brsaneconfig3', I get "brsaneconfig3: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.0, stripped"

Any other ideas?

share|improve this question
    
Try to add quotes on every string: brsaneconfig3 -a name="SCANNER" model="MFC-6890CDW" ip="192.168.1.90" –  Salem May 17 '13 at 12:07
    
Thanks for the suggestion, but I still get: "Syntax error: Unterminated quoted string" –  R B May 22 '13 at 10:42
    
Is your OS 32 or 64bit? Also what is the output of file /usr/local/Brother/sane/brsaneconfig3? –  Salem May 22 '13 at 12:22
    
OS is 64 bit. Output is: "ERROR: cannot open `/usr/local/Brother/sane/brsaneconfig3.' (No such file or directory)" –  R B May 29 '13 at 13:44
    
Try to install the drivers again. I have a very similar setup and everything works well. brsaneconfig3 should be a symlink to a existent file. In my system ls -la /usr/bin/brsaneconfig3 gives /usr/bin/brsaneconfig3 -> /usr/local/Brother/sane/brsaneconfig3 –  Salem May 29 '13 at 15:03
show 4 more comments

1 Answer

up vote 0 down vote accepted

Embarassing as it is to admit this, I am posting it in case someone else is stupid enough to make the same mistake I did. As it turns out, I did not have the 64 bit version of Ubuntu installed. I was sure I did, but I must have let myself be influenced by the Canonical standard recommendation for precise (12.04) to use 32 bit, or perhaps by those comments on the web indicating that 32 bit Ubuntu performs better than 64 bit with up to 3 GB RAM. More recent comments suggest that this is no longer the case. IAC, I was able to install the 32 bit version of the Brother driver without problems by following the instructions referred to in my original post, and it seems to work fine with xsane. In retrospect, I should obviously have taken the warning "package architecture (amd64) does not match system (i386)" more seriously. Oddly, I did not see this message after graduating from the driver version brscan3-0.2.11-4.amd64.deb to brscan3-0.2.11-5.amd64.deb unless I used the dpkg switch --force-architecture in addition to --force-all.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.