Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hi! I got an error at the last step. I am using Micromax MMX 355g 3G modem HSPA 7.2mbps. Configuration will be very difficult and detection of driver also difficult. I just did the above steps are fine upto modprobe statement and at last statement: usb_modeswitch -c /etc/usb_modeswitch.d/1dbc:0669. I got the error is no driver found, but usb storage driver is found and product id is also found:

Looking for target devices ...
   found matching product ID
   adding device
 Found devices in target mode or class (1)
Looking for default devices ...
   found matching product ID
   adding device
 Found device in default mode, class or configuration (1)
Accessing device 006 on bus 001 ...
Getting the current device configuration ...
 OK, got current device configuration (1)
Using first interface: 0x00
Using endpoints 0x01 (out) and 0x87 (in)
Inquiring device details; driver will be detached ...
Looking for active driver ...
 OK, driver found ("usb-storage")
 OK, driver "usb-storage" detached
 Could not send INQUIRY message (error -2)

USB description data (for identification)
Manufacturer: HSPA
     Product: HSPA
  Serial No.: 8444311594054030
Looking for active driver ...
 No driver found. Either detached before or never attached
Setting up communication with interface 0
Using endpoint 0x01 for message sending ...
Trying to send message 1 to endpoint 0x01 ...
 Sending the message returned error -2. Trying to continue
Resetting response endpoint 0x87
Resetting message endpoint 0x01
 Could not reset endpoint (probably harmless): -2
-> Run lsusb to note any changes. Bye.
share|improve this question
Similar question with the same answer - maybe merge these? – fossfreedom May 30 '13 at 21:55

Open terminal by pressing Ctrl+Alt+T and write this code:-

sudo gedit /etc/modules

Press enter

It will ask for your password, put it and press enter

then write these lines

usbserial press enter

option press enter

Save the file and close gedit.

Now restart your system.

After it open terminal by pressing Ctrl+Alt+T and write

sudo modprobe usbserialenter,

give your password, press enter then type

sudo modprobe optionpress enter.

  • Close the terminal.
  • Now connect your modem with the usb port.
  • Wait for few second, and you are done.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.