Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Sublime Text 2 in Ubuntu and on my Mac hitting command+p it lets me quickly select which file I want to open.

In Ubuntu hitten ctrl+p opens a print dialog. How can I disable that functionality in Ubuntu for Sublime Text?

share|improve this question
    
This is odd, because I'm almost certain Sublime Text doesn't have printing. That's one of my only complaints about it, actually :) Could you please check if you have any additional packages installed? –  Dylan McCall May 17 '13 at 4:18

3 Answers 3

up vote 3 down vote accepted

For me, pressing CTRL+P gives me the following output:

enter image description here

What I would suggest is to look for any shortcuts changed in the Keyboard options (System Settings). Maybe there is one that was set to that combination.

Secondly I would check Sublime to see if it has the default bindings:

enter image description here

Just in case you or someone changed some of them.

As mentioned by Goddard, make sure your default USER binding has the following line exactly like this:

{ "keys": ["ctrl+p"], "command": "show_overlay", "args": {"overlay": "goto", "show_files": true} }

that should solve the problem as tested by Goddard.

share|improve this answer
    
This is what mine said { "keys": ["ctrl+p"], "command": "show_overlay", "args": {"overlay": "goto", "show_files": true} }, –  Goddard May 17 '13 at 4:10
    
for some reason I had to put the key bindings in the - User area { "keys": ["ctrl+p"], "command": "show_overlay", "args": {"overlay": "goto", "show_files": true} } –  Goddard May 17 '13 at 4:15
    
@Goddard I am sorry for not adding that to the answer but yes, mine says the same in the USER default. Is this the one you are saying? –  Luis Alvarado May 17 '13 at 4:15
    
@Goddard did it solve the problem?. If yes I will edit my answer to include such information. –  Luis Alvarado May 17 '13 at 4:16

For some reason I had to put my Key Bindings in the User settings folder for it to work.

Strange. If you run into this problem try

{ "keys": ["ctrl+p"], "command": "show_overlay", "args": {"overlay": "goto", "show_files": true} }
share|improve this answer

If you have 2pdf plugin, remove that plugin.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.