Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have connected my Gateway laptop to my TV with an HDMI cord a million times, and I'm aware that you have to go into sound settings and select HDMI Audio. However, since upgrading to 13.04 there is no HDMI Audio option in the sound settings. I'm assuming I need to install something, but I'm not sure what.

Viewing the other questions on the same problem directed me here: https://code.launchpad.net/~ubuntu-audio-dev/+archive/alsa-daily/+packages

But I have no idea what to do from there.

share|improve this question

3 Answers 3

  1. Run this command in a terminal:

    sudo -H gedit /etc/default/grub
    
  2. Edit this line, from

    GRUB_CMDLINE_LINUX=""
    

    to

    GRUB_CMDLINE_LINUX="radeon.audio=1"
    
  3. Run:

    sudo update-grub
    
  4. Restart the system.

share|improve this answer
    
This worked for me. Thanks! –  Stephen Curran May 27 '13 at 18:01
    
can you explain your answer ? –  Francisco Corrales Morales Jul 12 at 23:01

That is what is called a ppa. It is just a place you can add to apt so it gets updated also. What you need to do is add the ppa to your system and update it... Here is what I did when 13.04 came out and it worked for my HDMI sound issue.

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
sudo apt-get update
sudo apt-get dist-upgrade
share|improve this answer
    
I added those 3 commands in the terminal, but I'm still having the same problem. HDMI Audio is still not an option in sound settings. –  Frank May 17 '13 at 21:41
    
It is not working from 13.10 on because of message "W: Failed to fetch ppa.launchpad.net/ubuntu-audio-dev/ppa/ubuntu/dists/saucy/main/… 404 Not Found". The page at ppa.launchpad.net/ubuntu-audio-dev/ppa/ubuntu/dists shows that raring is the last one. –  Michal Kováč Apr 17 at 20:49

Go to https://code.launchpad.net/~ubuntu-audio-dev/+archive/alsa-daily/+packages and install the latest oem-audio-hda-daily-lts-raring-dkms - ** ~precise1 deb and restart. If HDMI output is not the default selected, select it. Thats it.

I did not find the need to do any of the above suggestions.

I did the same for Ubuntu 13.04 connecting my CPU (Nvidia 450) through HDMI cable to Toshiba 19inch TV.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.