Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing 10.10 I used Hardware Drivers (Jockey) to install the graphics driver v11.2 for my ATI HD 5770.

After restarting to activate the driver all went well and the boot screen showed up but not like the normal one the text was rough on the edges and after the boot finished the screen turned black and no signal.

I have found some forum discussions about that issue but no fix worked for me. I use a DVI to VGA adapter and I have a View Sonic E70F CRT monitor.

this is the last thing i see before i get a no signal

i found a bug report at launchpad.net take a look

  • using sudo rm /etc/X11/xorg.conf and the rebooted the screen came on
  • after the boot or splash screen the desktop resolution is 1152x864

  • I can't use the CCC "catalyst control center": msg popup

  • I can't enable desktop effects

I have found that my EDID in my monitor is corrupt and Ubuntu is not reading my monitor when I set it to defalut and gives me this error:

enter image description here

In windows the display is read as generic non-PnP monitor and it can live with that while Ubuntu can't. The error message is the right size when I set my display as default.

People told me i can put refresh rates horizontal and vertical and screen resolution in xorg. Am I on the right track? How can I do that?

share|improve this question
1  
in the other post that guy got his issue which is like min fixed by DVI to HDMI adapter –  Hossam Riyad Mar 14 '11 at 17:52
    
Did you try using a DVI to HDMI adapter? –  Stefano Palazzo Mar 20 '11 at 16:29
    
my monitor is CRT so no way :D –  Hossam Riyad Mar 20 '11 at 17:46
    
Just statically set the Monitor parameters in xorg.conf or follow the boot to safe mode and configure directions from the answer below. If you boot to windows fine, then copy those settings. –  hbdgaf Apr 18 '11 at 6:32

3 Answers 3

There was a bug that had a problem with the ATI driver. The bug has now been fixed, so if you update it should now work, although I recommend you reconfigure your xorg.conf from scratch by moving the old one: sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

Link to the original bug: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/685682

share|improve this answer

The issue with Ubuntu is you need to manually specify in your drivers' control panel that "This monitor needs a signal, here's the specs".

On an nVidia system that I have, I have to connect the monitor, then open up the control panel for the nVidia system, hit 'Detect Monitors', and then I can configure what resolution and other options for the monitor. Note I've got a VGA monitor, but the same setup works for an HDMI connection (i.e. my desktop with an nVidia card connected to my 42 inch widescreen TV)

share|improve this answer
    
i cant see the login screen so i cant log in and play with the CCC "catalyst control center" –  Hossam Riyad Mar 15 '11 at 18:53
    
Then i think your issue is more than just a problem with your computer not giving your monitor a signal... perhaps the drivers broke it or did not configure itself correctly. –  Thomas W. Mar 15 '11 at 19:02

Hold down shift during boot to enter grub menu. Choose safemode. Now you will be able to reconfigure x.

You could try to uninstall all ati drivers before installing the driver by doing folllowing:

sudo stop gdm

sudo apt-get remove --purge xorg-driver-fglrx fglrx*

sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri fglrx-modaliases

sudo dpkg-reconfigure xserver-xorg

sudo apt-get install --reinstall xserver-xorg-core

sudo rm /etc/X11/xorg.conf

sudo rm -r /etc/ati/

And then reinstall the driver. Go to system -> Administration -> Hardware drivers.

share|improve this answer
1  
sudo rm /etc/X11/xorg.conf and the reboot. –  mount.cifs Mar 16 '11 at 6:04
    
Reinstall the driver. Go to system -> Administration -> Hardware drivers. –  mount.cifs Mar 16 '11 at 7:53
    
i did the steps in ur answer and that only removed the drivers and installed them back again so the problem came back no signal after splash screen i went in to safe mod low graphics and found xorg.conf and it contains the following Section "Screen" Identifier "Default Screen" DefaultDepth 24 EndSection Section "Module" Load "glx" EndSection Section "Device" Identifier "Default Device" Driver "fglrx" EndSection –  Hossam Riyad Mar 16 '11 at 8:17
    
Try the driver from ati/amd instead. Remove all drivers again and reinstall. –  mount.cifs Mar 16 '11 at 8:34
    
Are you running 32bits or 64bits Ubuntu? –  mount.cifs Mar 16 '11 at 8:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.