Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a fresh install of ubuntu 12.04 and noticed alt-tab wasn't working. I followed some advice and installed compizconfig settings manager, wherein I checked Application Switcher. Then alt-tab worked, but sometimes (lately, every time) it crashes the desktop. I'm using gnome classic (which by the way I have not been able to set as the default... I have to select it every time).

After hitting alt-tab, the screen freezes, and the mouse can be moved only briefly every few seconds, and clicking anywhere doesn't seem to do anything. Some parts of the screen become a bit distorted. One time it recovered, but then crashed again as soon as I clicked on the time in the upper-right corner.

Any idea how to fix this? Where can I look in the log files? Perhaps I can uninstall compizconfig (after all, it does come with a warning that it can wreck your system) but then how can I get alt-tab to work?

Many Thanks.

EDIT: I guess not many people have had this issue. I suspect it's a problem with my graphics card - perhaps it doesn't like the fancy effect involved with alt-tab window-switching. So a revision to my question would be: how do I enable alt-tab to switch windows for me in the simplest, safest, non-fancy way? Can I do it without compizconfig?

share|improve this question
    
Uninstalling CCSM won't help anything, because it's just a convenient way to edit a config file somewhere. –  Yet Another User May 18 '13 at 4:46
add comment

3 Answers 3

Select "Static Application Switcher" at the bottom of the config window in compizconfig settings manager instead of "Application Switcher" in the same window.

Alt+Tab should then work fine.

share|improve this answer
add comment
up vote 3 down vote accepted

Well, in case others with the same issue come across this, the solution was to disable the application switcher in compiz, and enable the static application switcher. The shift switcher also works nicely.

More info: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/971051

I noticed that if I used the gnome classic (no effects) desktop, a basic form of alt-tab worked fine, which was what I wanted, but I want some of the effects in the regular gnome classic desktop. For some reason my computer couldn't handle the fancy Application Switcher option.

share|improve this answer
add comment

Not to directly answer your question; but if you log in using Gnome classic and then log out without crashing the desktop. You should, in theory, then default to Gnome classic for subsequent log ins. I suspect that by crashing out, the log on settings are not being saved. On my computers it defaulted to Gnome classic after the first time I logged out.

share|improve this answer
    
Good idea, but even when I rebooted normally it didn't save my settings. –  rmp251 May 18 '13 at 3:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.