Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04 LTS with Wubi so I can choose to boot from Windows or Ubuntu with some simple key presses.

But when I tried to download Google Chrome for Linux (on the official website it says it works for Ubuntu too) 64-bit version in .deb format and Ubuntu Software Center opened it, I got an error that says

Cannot install 'libasound2:i386'

And I searched 'Google Chrome' in Ubuntu Software Center and it showed this 'Chromium Web Browser'. When I clicked Install, it asked me for 'authentication' (which never showed up before) and then it showed this:

Package dependencies cannot be resolved

This error could be caused by required additional software packages which are
missing or not installable. Furthermore there could be a conflict between software
packages which are not allowed to be installed at the same time.

What should I do? Is this because of my Wubi-installed Ubuntu?

share|improve this question
    
No, I also installed Ubuntu 12.04 LTS with wubi and were able to install chromium... did you try sudo apt-get install chromium ? –  M.Meintjes May 16 '13 at 11:51

2 Answers 2

up vote 0 down vote accepted

First thing's first: yes, you can install software on a Wubi-installed Ubuntu. But, to fix your problem, let's try installing Google Chrome through the command line instead of installing it through the Ubuntu Software Center. This way, if something goes wrong, we'll be able to see what exactly is happening.

First, open up a terminal. To do so, hit Ctrl+Alt+T. This is where we'll be entering the commands.

Second, enter in this command:

sudo apt-get update

Enter your password when prompted. This is basically a command that updates your "sources", so that when you install a program, you can do it seamlessly. You'll see lots of lines, and it'll stop in the end. If you get any errors like Err 404 Not Found when running this command, let us know and show us the output.

Next, we'll run the following command:

sudo apt-get install -f

This will attempt to fix (by downloading and installing) any missing files that are needed to run some programs. If it asks you "yes" or "no", type y and hit enter. This step might fix your Google Chrome installation.

Fourth, we'll run some commands to help clear up some unneeded files (incomplete downloads, unneeded packages, etc.), so type in these:

  • sudo apt-get clean, this will clean the cache.
  • sudo apt-get autoclean, this will remove partially downloaded files.
  • sudo apt-get autoremove -y, this will remove unneeded packages (dependencies).

Lastly, we'll try to install Google Chrome. This is going to be a different way that the way you did it, but bear with me. So, in that terminal, type in the following commands:

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

Once you type this, I think it will prompt you to hit the Enter key, so do it. It should say OK. After that, type the following:

sudo sh -c 'echo "deb http://dl.google.com/linux/chrome/deb/ stable main" >> /etc/apt/sources.list.d/google.list'

Once that's done, type the following:

sudo apt-get update

That's the first command we ran. This is to update the sources, because we just added the source (the "website" if you may) that we'll be downloading Google Chrome from. So finally, type in the following command:

sudo apt-get install google-chrome-stable

When asked yes or no, type y and hit Enter. This will start downloading and installing Chrome.

Now, I know that this looks like a pretty long way for installing software, compared to the Ubuntu Software Center, but all of these steps were to get rid of unnecessary stuff, and to see more information about errors, in case we're presented with some. But actually, the command to install software is just that last command. So, in the future, if you want to install VLC player for example, you would open up a terminal and type sudo apt-get install vlc. Yes, it's that simple.

If, at any point of these commands, you get an error, let us know and edit your question to show the error.

share|improve this answer
    
thank you for your detailed instructions! this worked very well. i'll study terminal in ubuntu later on. –  Greek Fellows May 19 '13 at 8:27

Wubi 64bit installs are supposed to have multiarch support, but it's missing (when not installing from the ISO). To fix:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install ia32-libs
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.