Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After trying to install the Nvidia drivers and got them working and then got them broken, I would like to check one important thing:

One of the main problems I run into was "Kernel version and Nvidia Driver version mismatch!". How to avoid this? How do I know that the newest NVidia driver out there is compatible with what I have already installed or have?

For example right now, I started with a fresh XUbuntu 13.04, Kernel: 3.8.0-21-generic. I know that there is a new NVidia driver for Linux: 319.17. So do I go with the "./*.run" file approach or do I set-up one of those external repositories, for example "xorg-edgers", what should be the correct approach?

Also, once I install them, how do I ensure that the NVidia drivers will not break with a Kernel update?

Thanks.

share|improve this question
    
For example, I can see a new Nvidia driver (319.17) on xorg-edgers. How different is that to the 319.17 listed on the official NVidia Linux Driver page? –  symbolix May 16 '13 at 11:07
    
The 319.17 driver will available in the xswat ppa eventually, the binary from nvidia's site is not for beginners, it has to be reinstalled after a kernel update [Ctrl]+[Alt]+[F1] would get you to where you need to be in install there binary blob –  GM-Script-Writer-62850 May 16 '13 at 14:30

2 Answers 2

There are three kinds of drivers:

  • tested and stable drivers
  • tested and presumably stable drivers
  • brand new bleeding edge drivers

As the name says drivers from the bleeding edge side (be it from the xorg-edgers ppa, or downloaded binaries from the manufacturer) are not meant to be stable. They are there for us to test them, and to report or fix bugs we may find.

Only after these tests turned out to be successful and bugs were fixed the drivers gradually mature to stable (found in ppa:ubuntu-x-swat/x-updates) and finally get their way into the official repositories.

Therefore in case we do not want to install drivers which may break our system, or are incompatible with our kernel, or other kernel modules we should refrain from installing bleeding edge drivers.

A misbehaving alpa or beta driver may be easier to purge if we had installed them from a ppa rather than from a binary.

share|improve this answer
    
Thanks Takkat. This was very helpful. So I have added ppa:xorg-edgers/ppa to my sources, I will follow your suggestion for not jumping on those and installing something from there. But I still do not see the Nvidia driver amongst the updates being broadcasted by them, despite the fact they are listed in their archive? I will add x-swat as well now. –  symbolix May 16 '13 at 11:38
    
Once they work the ppa will update. Installing binaries is faster but quite risky. –  Takkat May 16 '13 at 11:41
    
Cool. Thanks for the information. So to install the latest and the most stable and official Nvidia driver, I will need to do this: sudo apt-get install nvidia-current ?? This will get the driver from a trusted and tested source, right? –  symbolix May 16 '13 at 11:45
    
you could also go for nvidia-current-updates but these will only give you old (but stable) 304 drivers. Also see: askubuntu.com/questions/61396/… –  Takkat May 16 '13 at 11:50

I think there is already automatic updating for lasted nvidia drivers directly in update menu (look for additional drivers menu)

share|improve this answer
    
Nvidia does not appear in the Additional Drivers section by default. At least not for me. On the other side, I guess all the GL and XServ functions need to be turned off in order to install the driver, meaning: It needs to be done through a terminal with X off. –  symbolix May 16 '13 at 11:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.