Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Kubuntu 13.04 (last version) and lightdm

I want to change my login screen background (not my wallpaper after I type my password. I'm talking for the image you see WHEN you type your password). It shows a greyish "image" right now. When I tried to use a picture from home and restarted the screen became white and it didn't show my image. I searched and found out that it because of some setings.

The problem is I'm very new to kubuntu and I don't want to mess things up with complicated setting from the terminal etc or to mess aroud with the root files because I won't be able to fix things.

Is there a simple solution as to how can I change this image? There is no option for me to download something there but only to load a picture.

Thank you very much in advance

share|improve this question

2 Answers 2

up vote 2 down vote accepted

At here

KDE System Settings > Login Screen (LightDM); Theme tab

Background image

enter image description here

and the log in screen has new background.

Why it is not working - White background - Check these

1) The image file has wrong extension

Tested with jpg picture with the png extension. The file properties is showing the right image format.

Right click the file > Properties: Information tab

enter image description here

The picture should have correct extension - If not the LightDM can't read the picture data.

2) The image file has wrong permissions

The user has forbidden the read of the image.

enter image description here

Right click the file > Properties: Permissions tab

The Owner/Group/Others should have the right to read the picture data.

share|improve this answer
    
It worked! :D It was the image setting that was the problem. Thank you very much! It was extremely helpful :D Now all I have to do is figure out how to change profiles with this format :P Thank very very much :) –  Lucky Strike May 16 '13 at 17:23

In my situation I found another situation where it doesn't work (Why it is not working - White background). We have two possible causes above. Here is a third one.

I stored my wallpaper in the std user wallpaper folder of KDE (with Kubuntu 14.04):

/home/[user_name]/.kde/share/wallpapers/

It works for the backgrounds, but not for the login screen. I found out that even if jpg file permissions is allowed (RW/RW/R), /home/[user_name]/.kde/share/wallpapers is more restricted (RW/-/-). This is the reason why it doesn't work.

I just moved my jpg file to another location and it solved the issue.

share|improve this answer
    
You need to have the right premissions on the directories too. From top root directory / down through all to /h/[u]/.kde/s/wallpapers. So see to it that they have at least x rights, and possible r rights on wallpapers. The directories above wallpapers only need r if you want to give the right to list the contents of that directory. But as you know the names inbetween, you only need x to have access to it and lower directories/files. –  Anders yesterday

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.