Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm going to be buying a sata 3 motherboard (Gigabyte GA-970A-DS3) and a new SSD (SATA 3) as my boot/programs disk.

In addition, I will be using my 2 old maxtor diamondback 10's (7200 - 300gb each) for data storage. One of which is SATA 1 and the other is SATA 2 (just to confuse things!)

I want the SSD to be fully independent and running in AHCI, for best performance.

I want the 2 HDD's to be in RAID (seperate from the SSD, to avoid any speed kill).

I am also running an IDE DVD drive in SATA, using a IDE-SATA converter. How will this fit into the configuration and will it work in AHCI mode?

How do i go about setting up this configuration? Or is there a better option?

The motherboard has 6 SATA ports, labelled 0-5. I've no idea what goes where or which ports are controlled by which controllers so some help here would be great!

Any answers here would be really appreciated. Thanks guys!

share|improve this question
    
have a look at this: SATA 1 & SATA 2 RAID –  M.Meintjes May 16 '13 at 8:03
add comment

1 Answer 1

i did make a video for installing to a SSD and a HDD - http://www.youtube.com/watch?v=2sPGEwqoXA0
you should know that the GUI installer for ubuntu does not support raid
If your bios allows you to set 2 of the ports in raid and the rest in ahci it is possible, you probably would need a second sata controller for that
sata 1, 2, or 3 it does not matter as a hdd can't benefit from sata 3 as they are too slow, if your sata 2 drive is faster than your sata 1 drive you may not be able to raid them, raid works best with 2 of the same model
if you have 2 sata 1 posts i don't see that being a issue though
I would suggest RAID 1 for the HDDs (i think that is the one that does not loose data if 1 drive fails)
you may be able to do a software raid (remembered this as a i was typing this) that will only use some of your ports for raid, and have the bios set in ahci
https://help.ubuntu.com/community/Installation/SoftwareRAID
if someone can edit this to make it more readable please do, it is late here and i am sleepy
Edit: as for your IDE drives, i just looked at the motherboard, but i dont see a plug for a ribbon cable on the motherboard, unless you have a pci card for that (or ide to sata adapter) you are not going to be using them

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.