Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a directory in the /dev dir called media/windows. I need to mount the /windows directory to a ntfs file system partition in /dev called sbd1. I have tried mount /dev/media/windows /dev/sdb1 and it says I need to state what file system type so then I tried adding -t ntfs at the end and it tells me it failed to open or mount /windows because it's a directory... but that is exactly what my assignment in this class says to do.

share|improve this question
add comment

4 Answers 4

I'd like to offer some advice rather than gift wrapping an answer. Funny thing about computers. They're built by humans to be logical and sensible. They aren't designed to be tricky, but they are complex, and the documentation, when there is documentation at all, never covers all possible contingencies.

Forgive me for making assumptions, but it seems to me that you are in possession of a small puzzle, and all the pieces to solve it. Try different combinations. Re-read the documentation. Type

man mount

in the terminal for a worthy guide to all things mount. Don't be (too) afraid to guess wrong and break something. This is the pattern with every computing problem you will ever encounter.

I work with a recent college graduate who can barely wipe his nose unaided. He has to run every tiny piece of every encountered problem past other staff before he can act. Some might be flattered to guide him. Others might resent that he values his own time more highly than the time of his co-workers. If you're planning a career in computers, you can hope to team up with the flattered, but you're certain to run across the resentful. Take another stab at it.

Then again maybe you're an English major who just wants to be done with his homework. If so I apologise for the unwarranted career advice. Still, take another stab at it.

share|improve this answer
add comment

Ok. I used mount -t ntfs /dev/sdb1 /media/windows and it returned no errors. Then I entered mount and found "/dev/sdb1 on /media/windows type fuseblk (rw,allow other,blksize=4096)" so I can mount the /sdb1 partition to the /windows directory, but the assignment specifically says to mount the /media/windows to /dev/sdb1.

Also... I seem to just not have an unmount command so I can't reverse this to attempt to mount them the other way. I type unmount and just get command not found.

share|improve this answer
add comment

I also keep getting an error when trying different mount options saying that it can't mount because /dev/sdb1 is not a directory.

share|improve this answer
add comment

/dev is usually a tmpfs mount that is managed by udev, so it has to be the actual same file system as on the host machine. That means that you would need to use the bind mount method.

mount --rbind /dev/media/windows /dev/sdb1 -t ntfs

share|improve this answer
    
I tried adding the -rbind command and all I get is "invalid option -b" and a list of possible mount commands. –  Aaron May 16 '13 at 17:15
    
Try edited command –  22lk94k943 only May 16 '13 at 20:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.